Grid Issue? (33.3 KB)
Run the project.
At the bottom of the page you will see a button "New Form".
An inherited form will be created in a new tab sheet.
A new button "Data" will appear. Press it.
A grid will fill with some data.

Again press "NewForm".
A new tab sheet will appear and again press data to fill the grid.
So far so good.
Go to first tab sheet. The grid is still there but unusable.

Is there a problem with my code or something else?

Thank you :slight_smile:

Not sure what you mean by unusable. Clicking the data button adds more data to the correct grid.

No lines, no selected row appears any more and you can't click on a specific row.

Interesting, if you click data again, it seems to come back to life. I thought it might be a case of the tables having the same id, but that doesn't look like to be the case.

As you say comes back to life and becomes unresponsive the grid of the other tabsheet.

I found another problem.
When I am trying to open unit3 in the IDE I get the following error
If I click ignore or ignore all the unit opens without an issue.

Is form 3 inherited? That occurs on all my inherited forms with a TWebDBGrid or TWebDBControl where the grid is declared on the base form and the fields in the table declared on the inherited form. I've not actually tried it with the fields declared on the base form, but it might well have the same result.