FlexCel installation error in Delphi CE 11.3

I just purchased FlexCel for VCL & FMX.

When I try to do an automatic installation in Delphi CE Ver. 11.3 all the units seem to be compiled without errors, but then this error occurs (Text copied from the log file FlexCel_build_log.txt):

Exception: Source file doesn't exist: C:\Users\jagre\Documents\TMSSoftware\FlexCelVCLNT\Packages\d11\bpl\Win32\FlexCel_Core280.bpl

The file FlexCel_build_errors. txt is empty.

I am only installing the Win32 and Win64 versions of FlexCel.
/Lars Renman

Can you post the full FlexCel_build_log.txt ? If the bpl doesn't exist, there either was an error compiling, or there is an issue with the AntiVirus. Check that the file isn't quarantined in your antivirus, it sometimes happens that it erases it.

Here's the log file.

I have read it carefully now. It seems the units were not compiled ("This version of the product does not support command line compiling.") even though it states
Build succeeded
0 Warning(s)
0 Error(s)
for all units.

FlexCel_build_log.txt (45.1 KB)

/Lars Renman

Yes, this is the error you get if you try to compile from the command line in a Delphi trial or in "Delphi Starter" (or "Delphi Community or whatever it is called now).

Those delphi versions do not come with command line compilers, but instead of just not including them (so the setup could detect say that drcc32.exe doesn't exist), they include "fake" drcc32.exe and similar compilers, that just say "This version yada yada command line compilers", but they also report "0 errors" (and warnings) and also return an error code of 0, so the setup can't possibly know that nothing was compiled.

Usually, I would tell you that for Delphi starter, since they don't have command line compilers, you need to install manually, following the instructions here: FlexCel Installation Guide | FlexCel Studio for VCL and FireMonkey documentation

But luckily now we have a better way. Our next-gen installers (see TMS Software | Blog ) support, even if poorly, Delphi Starter. It isn't a great support, because as we don't have command line compilers we can't really compile from the command line, but it works. Basically what is does when it detects this is Delphi Community, is to automate Delphi to compile the packages, which results in many dialogs (some of which you might have to close manually). It isn't great, it doesn't work in parallel, but it works and avoids the manual work of installing by hand. (of course, if you have real command line compilers, Smart setup will use them)

So first we need to confirm you are installing into a Delphi Community/Starter. If you have another Delphi version, then there is a problem with your install and you might need to reinstall Delphi.

If you are installing in Community/starter, then do the following:

  1. Uninstall the "setup.exe" FlexCel you just installed. So we don't get conflicting installs.
  2. Download smart setup from: TMS Smart Setup introduction | TMS Smart Setup documentation
  3. create a folder where you want to install the components, extract tms.exe there, and then open a command line window in that folder.
  4. write tms credentials to enter your registration data.
  5. write tms config and configure the .yaml file as you want it. As this is Delphi CE, make sure you select only win32 and win64 if you want only that, since compiling by automating the IDE is slow and full of dialogs, so the less you compile the better.
  6. Write tms install tms.flexcel.vcl.

That should be it, wait some time while the components are compiled and installed.

From then on, every time we release a new version, you can just write tms update and it will get the newest version, compile it and install it.

I just realized you mentioned "Delphi CE" in your original post :slight_smile:
Well, my above answer still stands, but I should have been able to tell you sooner the error. I just didn't saw it the first time.

Your smart installer solution seems to have worked.
The yaml file settings were a little confusing, but it seems I made the right guesses of what to enable.

Thanks a lot!

/Lars Renman