Error installing Flexcel for MacOS64 and MacOSArm64 on MacOS 14 Sonoma

MacOS 14.1.1 with Delphi 12.
Installing Flexcel 7.19.1 fails with a linker error for MacOS (64 and Arm64).
Trying to build FlexCel_Core290 manually from the project raises the same error. All other platforms work ok.
I've imported MacOSX14.0.sdk from the system, and wonder if that's causing the linker error?

C:\Program Files (x86)\Embarcadero\Studio\23.0\bin\dccosx64.exe -$O- -$R+ -$Q+ --no-config -M -Q -Z -TX.dylib -AGenerics.Collections=System.Generics.Collections;Generics.Defaults=System.Generics.Defaults -DDEBUG -E.\OSX64\Debug -I"C:\Program Files (x86)\Embarcadero\Studio\23.0\lib\OSX64\release" -LEbpl\OSX64 -LN.\OSX64\Debug -NU.\OSX64\Debug -NSSystem;Xml;Data;Datasnap;Web;Soap; -O"C:\Program Files (x86)\Embarcadero\Studio\23.0\lib\OSX64\release";"C:\Program Files (x86)\Embarcadero\Studio\23.0\Redist\osx64" -R"c:\program files (x86)\embarcadero\studio\23.0\lib\OSX64\release\EN";.\OSX64\Debug;"C:\Program Files (x86)\Embarcadero\Studio\23.0\lib\OSX64\release";"C:\Program Files (x86)\Embarcadero\Studio\23.0\Redist\osx64" -U"C:\Program Files (x86)\Embarcadero\Studio\23.0\lib\OSX64\release" --syslibroot:C:\Users\chris\Documents\Embarcadero\Studio\SDKs\MacOSX14.0.sdk --frameworkpath:C:\Users\chris\Documents\Embarcadero\Studio\SDKs\MacOSX14.0.sdk\System\Library\Frameworks;C:\Users\chris\Documents\Embarcadero\Studio\SDKs\MacOSX14.0.sdk\System\Library\PrivateFrameworks -V -VN --description:"FlexCel Core Library" --macosx-version-min:10.9 -JL -NH.\OSX64\Debug -NO.\OSX64\Debug -H- -W- FlexCel_Core.dpk
Embarcadero Delphi for Mac OS X 64 bit compiler version 36.0
Copyright (c) 1983,2022 Embarcadero Technologies, Inc.
Linker command line: "C:\Program Files (x86)\Embarcadero\Studio\23.0\bin\ld.exe" -arch x86_64 -o bpl\OSX64\bplFlexCel_Core290.dylib -e __ZN12Flexcel_core14initializationEv -dead_strip -dead_strip_dylibs -mark_dead_strippable_dylib -exported_symbols_list bpl\OSX64\FlexCel_Core.exp -dylib -export_dynamic -macosx_version_min 10.9 -syslibroot C:\Users\chris\Documents\Embarcadero\Studio\SDKs\MacOSX14.0.sdk -F C:\Users\chris\Documents\Embarcadero\Studio\SDKs\MacOSX14.0.sdk\System\Library\Frameworks -F C:\Users\chris\Documents\Embarcadero\Studio\SDKs\MacOSX14.0.sdk\System\Library\PrivateFrameworks -L "C:\Program Files (x86)\Embarcadero\Studio\23.0\lib\OSX64\release" -L "C:\Program Files (x86)\Embarcadero\Studio\23.0\Redist\osx64" -rpath $ORIGIN -install_name @rpath/bplFlexCel_Core290.dylib -filelist bpl\OSX64\FlexCel_Core.lnk
dsymlink command line: "C:\Program Files (x86)\Embarcadero\Studio\23.0\bin\dsymutil.exe" -flat -o bpl\OSX64\bplFlexCel_Core290.dylib.dSYM bpl\OSX64\bplFlexCel_Core290.dylib
C:\Program Files (x86)\Embarcadero\Studio\23.0\Bin\CodeGear.Delphi.Targets(425,5): error F2588: Linker error code: 3221225477 ($c0000005) [C:\Users\chris\Documents\tmssoftware\FlexCelVCLNT\Packages\d12\FlexCel_Core.dproj]
Done Building Project "C:\Users\chris\Documents\tmssoftware\FlexCelVCLNT\Packages\d12\FlexCel_Core.dproj" (Make target(s)) -- FAILED.


"C:\Users\chris\Documents\tmssoftware\FlexCelVCLNT\Packages\d12\FlexCel_Core.dproj" (Make target) (1) ->
(_PasCoreCompile target) ->
C:\Program Files (x86)\Embarcadero\Studio\23.0\Bin\CodeGear.Delphi.Targets(425,5): error F2588: Linker error code: 3221225477 ($c0000005) [C:\Users\chris\Documents\tmssoftware\FlexCelVCLNT\Packages\d12\FlexCel_Core.dproj]

I haven't seen this particular error myself, but a google search reveals it seems to be very common for some users:

A common thing in all reports seems to be that it only happens when compiling with debug dcus. (And while I've not seen this one myself, I've seen a similar ones in other platforms, related to debug dcus)
So I wonder if you can try to install with debug dcus unselected in the FlexCel setup, and confirm if the problem still exists? We are currently about to release 7.20 so I am not sure we will be able to release a fix for this, but if it is just disabling the debug paths for macos it can be feasible to change.

Thanks Adrian, I’ll give that a try and let you know if it works

I've just tried installing without debug DCUs and it still fails with this error on OSXARM64:

C:\Users\chris\Documents\tmssoftware\FlexCelVCLNT\Source\ error F2084: Internal Error: URW7834 [C:\Users\chris\Documents\tmssoftware\FlexCelVCLNT\Packages\d12\FlexCel_Core.dproj]

I've tried building the project from the sources directly in D12, and it builds all without problems (Debug or release), but when I try to install the component design package it says that the FMX_FlexCel_Components_DESIGN290.bpl module couldn't be found, even though it's at that location.

This is blocking me really badly, so any help you can offer would be greatly appreciated.

FMX_FlexCel_Components_DESIGN290.bpl module couldn't be found

This message normally means an error with the Windows Path. There are 2 possibilities:

  1. If you installed manually, you forgot to add the folder where FMX_FlexCel_Components_DESIGN290.bpl is to the windows path. (the setup doesn't add a windows entry, but it creates a symlink)
  2. You don't have ($PATH) as an entry in your Environment Variables Override for the variable "PATH": (note how it ends with ;$(PATH).)

Some components sadly change that variable removing the $(PATH) and make any other component changing the path fail.

In any case, we've just released 7.20 some minutes ago. I would recommend to uninstall FlexCel completely, make sure to remove any manual changes you made, and try it with smart setup (see TMS Smart Setup available )

Just download tms.exe from there, open a command line, go to the folder where you want to install and type:

tms install tms.flexcel.vcl

I've triple checked it here, it installs ok in macOS Arm64 and macOS x86, but so does setup.exe (both 7.19 and 7.20). I've tried it in 3 different machines, couldn't see an issue in any of them. If you are still having the issue, you might need to reinstall the macOS support in delphi (tools->manage features), remove the sdks and try again. Can you deploy an app not using FlexCel to macos?

I uninstalled previous FlexCel components, making sure to delete the various install and data directories so it was a clean install.
I tried the new 7.20 setup.exe and it still failed with the same errors for OSX64 and OSXArm64.
I can create and run an app for OSX64 and Arm64 from D12 without errors.
I tried the new tms.exe command line tool, which looks great. However, it failed trying to build for OSX64, OSXArm64 and Android32 (and 64).
In the end, I followed your other instructions, added the new bpl location to the Windows path and managed to manually build and install the components that way.

I'm happy to send over the logs generated by tms.exe to investigate if you want them. Please let me know where to email and for whose attention.


Update: I thought the manual install was successful but apparently not.
When I try to do an iOS build of the FLX demo app, it fails to link with the error:

[DCC Error] E2597 ld: building for iOS-arm64 but attempting to link with file ("c:\Development\Tools\Products\tms.flexcel.vcl\Packages\d12\iOSDevice64\Debug_UCoreSheetInfo.o") built for unknown-unsupported file format ( 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 )

I'm not sure where to go from here. I've never had any problems with Flexcel in the past, nor did I have any issues installing or using it with the Delphi 12 betas so not sure what's changed with the production version.

Update: It looks like this was due to an environment issue within my Delphi 12 setup.
I've corrected the environment issues and TMS Flexcel now installs ok.

Thank you for you help.

Thanks for informing us, it is great to know it was fixed.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.