Error compiling Flexcel for FPC (MacOS)


According to your guide
I have compiled flexcel_core_lazarus.lpk
Next flexcel_xlsadapter_lazarus.lpk error:
Fatal: Can't find unit _UXlsBaseEncodeFormula.Ptg used by _UFormulaTokens.TBaseParsedToken.

Maybe the problem is that the file is named _UXlsBaseEncodeFormula.ptg.pas in real?

The .pas shouldn't matter, the name of the unit is _UXlsBaseEncodeFormula.ptg. Lazarus should handle this automatically, and it does here in all machines I've tested it. (see Library path - Free Pascal wiki)

Have you tried going to package->Install/Uninstall packages and make sure that flexcel_core_lazarus is installed before compiling flexcel_xlsadapter_lazarus?

Another idea: I had to change directory structure:
/flexcel/lazarus (packages)
/flexcel/package/lazarus (packages)

before didnt found any files

Any progress about this?

I could reproduce it now, it looks like some change in the lazarus trunk caused it since it was working before. But we are looking into it, adn trying to get it working for next week. In fact, we are looking into a installer that should work with lazarus in win/mac/linux and that should avoid the manual installer, so we are really interested in having it working by then. See TMS Software | TMS Web Academy

Do you at least remember revision of last working trunk? I think I can with fpcdeluxe install exact revision?

Still no progress?