Downloading with SFTP


What is the best way to download files with SFTP ?
If tried WebCopy, but cannot configure it.
If the URL is needed, what should I put there ?
With FileZilla I see the directory is "/.cm4all/mediadb/Downloads/sleutels" (hosted by Strato), and the domain is . So in this case, what shoul be the URL ?

kind regards,

Dirk Janssens.

WebCopy.Items[x].FTPHost should be ,
WebCopy.Items[x].Protocol should be wpSFTP
Set the credentials with WebCopy.Items[x].FTPPassword / WebCopy.Items[x].FTPUserID

Hi Bruno,
I tried that. no luck.
BTW : in FileZilla I use :
host : s
User :

With both it does not work ( access denied )

If I Use "" , it seems to work, but the file is not copied. No errors .

I logged all the events, and get the following :


It seems even if target dir and targetfilename are assigned, i still need to set url ?
Is that correct ?

kind regards,


FTPHost needs to be set to ''
Try to set URL to the filename you want to download.

then I get :
"WebCopy2ErrorInfo Errorcode: 3 , Cannot create target file TMS_WEBCOPY_TEST.txt "

It tries to create c:\.cm4all\TMS_WEBCOPY_TEST.txt
but I thought it would store the file in the application's directory (like in the demo).
I thought "targetdir" is the directory on the server.

URL should be TMS_WEBCOPY_TEST.txt
Either is can store it in the default SFTP folder or it uses TargetDir to perform a CHDIR with on the FTP server and then store the file in the new selected folder on the FTP server.

I am not trying to store anything on the ftp server. I try to download the file... Is that possible?

OK, it works now. Thank you.
What confused me was the "targetdir". I thought that was the directory on the server.
Setting the target to 'd:\tmp\ , and using the URL to navigate from the root on the server works.
So this works:
URL = '/.cm4all/mediadb/Downloads/sleutels/TMS_WEBCOPY_TEST.txt'

kind regards,