Delphi 12 Problem adding library paths

I installed webcore in Delphi 12.
The library path editor for WebCore is failing when adding a path, Initially it said error about the string list out of bounds. Now only shows a runtime error "access violation at address 6CBA9EF6 in module coreid290.bpl. Read of address 0000000".
It only happens in the tools/options/TMS Web/library path.
If I go to the tools/options/language/delphi/library and change anything in library path, it works fine.

I just had the same issue, Delphi 12 and used the tmssmartsetup
Was able to add them manually using the string below


TMS Web Core is not installable via TMS Smart Setup yet, I don't see how this relates.

I actually don't know what the tmssmartsetup is. I use the TMS Subscription Manager to install the FNC suite, but for TMS WebCore I just do it manually, uninstall first and then install the new version, for both D11.3 and D12.

Anthony, when you say you added manually that path, where or how did you added it? to the registry, to the project source, or where?

BTW, the TMS Subscription Manager (most recent versions) always messes up the delphi library path, adding duplicate paths, which sometimes confuses Delphi and makes it crash.
Since a couple of years ago, after discovering the problem, I automatically go to options and delete duplicates or invalid paths in the delphi library path after doing installs with Subscription Manager..

I used tmssmartsetup to install only the fnc components and installed WebCore manually in D12 via the installer.

I was getting TMSFNCTypes not found on compiling my program and found your post about the setting tools/options/TMS Web/library which was empty.

When adding via the library path editor it failed to save the path back to the options screen and I was getting an exception error.

By manually typing the paths into the library path edit box on the options dialog I was able to save the paths and get the program to compile.

I did not have this issue in D11

You are right. I usually don't enter paths in that way because it is like looking outside from a liiiiitle window and prone to errors, just like the default environment variables on windows. But thanks, I did it that way.

I was able to edit them in them using the editor, just not Add them

Next update should fix this.