TMS Smart Setup - FNC install errors in D12

With the new installer, the installation of the FNC components under D11 works for me without any problems, but not for D12.
No error message appears during installation, but when starting Delphi 12 I get error messages for the modules:

  • FMX_TMNSFNCGridExcelBridge_Design290. bpl
  • VCL_TMNSFNCGridExcelBridge_Design290. bpl
  • VCL_Flexcel_Components_Design290.bpl
  • FMX_Flexcel_Components_Design290.bpl
  • TMSFNCGanttChartPkgDE290.bpl

Specifically, the path is not found:

However, the files are actually present in the folder and I did not receive a direct error message during installation.
What could have gone wrong here?

The component TMS FNC Grid Excel Bridge 3.2.1 is only available in the new installer.
Only version 3.2.0 is available on the website and in the old installer.
However, this does not seem to support D12 yet, at least I cannot select D12 when installing.

About the path not found issue, make sure to check your path env variable, as mentioned here:

If that was the problem, I'd like to know what your current path override was, so we can get a better idea of what is changing that path. It looks like we will have to automatically fix this in a future smart setup version.

About the second issue, both 3.2.0 and 3.2.1 are the same (the .1 diff is because of a smartsetup fix, it doesn't affect the 3.2 normal setup), and both support d12, but for some reason many users keep getting 3.1 instead when downloading that file. See for example TMS VCL Grid Excel Bridge for Delphi 12 - #12

So we are providing the setups directly here:
Vcl bridge:

Fnc bridge:

Thanks for the quick feedback

This was it - it was effectively due to the missing entry.

The complete entry in D11:

5.0.0\Library\RAD Studio 11 Alexandria\Win32\Release\Bpl;C:\Users\lrcu\Documents\Embarcadero\Studio\22.0\CatalogRepository\Skia4Delphi-5.0.0\Binary\Shared\Win32;$(PUBLIC)\Documents\Embarcadero\InterBase\redist\InterBase2020\IDE_spoof;$(PATH)

and in D12:

C:\Users\lrcu\Documents\Embarcadero\Studio\23.0\CatalogRepository\FastReport-2023.3\RS29\VCL\Win32;C:\Users\lrcu\Documents\Embarcadero\Studio\23.0\CatalogRepository\FastReport-2023.3\RS29\VCL\Win64;C:\Users\lrcu\Documents\Embarcadero\Studio\23.0\CatalogRepository\FastReport-2023.3\RS29\FMX\Win32;C:\Users\lrcu\Documents\Embarcadero\Studio\23.0\CatalogRepository\FastReport-2023.3\RS29\FMX\Win64;C:\Users\lrcu\Documents\Embarcadero\Studio\23.0\CatalogRepository\FastReport-2023.3\RS29\VCL\Win32;C:\Users\lrcu\Documents\Embarcadero\Studio\23.0\CatalogRepository\FastReport-2023.3\RS29\VCL\Win64;C:\Users\lrcu\Documents\Embarcadero\Studio\23.0\CatalogRepository\FastReport-2023.3\RS29\FMX\Win32;C:\Users\lrcu\Documents\Embarcadero\Studio\23.0\CatalogRepository\FastReport-2023.3\RS29\FMX\Win64;C:\Users\Public\Documents\Embarcadero\InterBase\redist\InterBase2020\IDE_spoof;C:\Program Files (x86)\Embarcadero\Studio\23.0\bin;C:\Users\Public\Documents\Embarcadero\Studio\23.0\Bpl;C:\Program Files (x86)\Embarcadero\Studio\23.0\bin64;C:\Users\Public\Documents\Embarcadero\Studio\23.0\Bpl\Win64;C:\Program Files\Eclipse Adoptium\jdk-\bin;C:\Program Files\Eclipse Adoptium\jdk-\bin;C:\Program Files\Python310\Scripts;C:\Program Files\Python310;C:\Program Files\Microsoft\jdk-\bin;C:\Python310\Scripts;C:\Python310;C:\Program Files (x86)\Embarcadero\Studio\22.0\bin;C:\Users\Public\Documents\Embarcadero\Studio\22.0\Bpl;C:\Program Files (x86)\Embarcadero\Studio\22.0\bin64;C:\Users\Public\Documents\Embarcadero\Studio\22.0\Bpl\Win64;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0;C:\windows\System32\OpenSSH;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\Microsoft SQL Server\150\Tools\Binn;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\170\Tools\Binn;C:\Program Files\dotnet;C:\ProgramData\chocolatey\bin;C:\Program Files\Git\cmd;C:\Program Files\TortoiseGit\bin;C:\Program Files\nodejs;C:\T\FNC\BIZ\Aurelius\Bin;C:\Program Files (x86)\Windows Kits\10\Windows Performance Toolkit;C:\Users\lrcu\AppData\Local\Microsoft\WindowsApps;C:\Users\lrcu\AppData\Roaming\npm;C:\Users\lrcu\AppData\Local\Programs\Microsoft VS Code\bin;C:\Users\lrcu.dotnet\tools

I have just downloaded the file from the homepage ("my Account") and compared it with the file "" downloaded from the old installer.
In both cases, the wrong file is effectively present (3.1. from 9.9.2021).

Thanks for the extra information. I've confirmed here that installing fastreport breaks your path env override (it replaces the $(PATH) var by the actual path, and so it never updates anymore. We'll contact them to fix it.

Apparently there are "other" errors:

D12 now starts without an error message, but at least the components:

  • TMSFNCGrid
  • TMSFNCGridExcelImport
  • TMSFNCGridExcelExport

are not found.

When loading the demo programme
"A:\T\Products\tms.flexcel.vcl\Demo\Delphi\Modules\25.Printing and Exporting\20.CustomPreview"
the component "TFlexcelPreviewer" is not found. If I compile the same demo programme via the main project "MainDemo", it basically works.
I suspect that something is wrong with the paths here too.

Check that the packages are "checked". When there is an error like th one you had above, normally Delphi disables loading the packages for the next time. You can see it at Menu->Components->Install Packages. Look for flexcel there and for the filters, and see if their checkbox is checked. If it isn't check it.

If that doesn't work, probably a tms build -all should fix it.

I tried it with "tms build -full". But it did not solve the problem.
Then I installed TMSFNCExcelBridge manually and it worked immediately.

Many thanks for your support :-)