can't clear the text in TIWAdvLUEdit

i have this very simple procedure :

procedure TfrmMainAdmin.IWRadioGroup1Click(Sender: TObject);
  case IWRadioGroup1.ItemIndex of
    0, 1 : TIWAdvLUEdit1.MaxLength:=30;
    2, 3 : TIWAdvLUEdit1.MaxLength:=9;


so there is a IWRadioGroup with 4 options, and a TIWAdvLUEdit that needs to get the focus and get cleared, but for some reason it does everything but clearing the text in it.

i also tried TIWAdvLUEdit1.Text:=''; and Self.Text:='';  from inside the OnAsyncEnter but still doesn't clear the text.

any idea?

for somes trange reason it's working 100% now but ONLY when the TIWAdvLUEdit1 is inside a region.
bug maybe...?

(another) update:

ok, so now i'm sure there is a bug in the TMS edit component after all... :
trying to show an edit (TIWAdvLUEdit, TIWAdvEdit etc) after it was hidden, when the DecimalPoint=#0 leads to an endless show of the animated circle.

so let's say i have a region with a TIWAdvLUEdit in it, and this region is hidden.
now, if i want to show it and the TIWAdvLUEdit's DecimalPoint property is #0 then it all get stuck and there is no error message to tell my why

I have not been able to reproduce this issue.
The IWAdvLUEEdit text is cleared correctly also when the control is placed directly on the form (i.e. not on an IWRegion)
Can you please explain exactly how to reproduce this issue?
Bart Holvoet2012-07-17 03:23:58

The DecimalPoint is only used when EditType is set to etFloat.
If you do not require a DecimalPoint then you should change the EditType to etString, etNumeric, ... and leave the DecimalPoint set to ",".