cannot load into TMSFNCWebBrowser

I am hoping someone can help me with this issue. Recently, it appears that cannot be loaded into a TMSFNCWebBrowser component on a MacOS computer.

in other words: TMSFNCWebBrowser1.URL := '';

It used to work fine, but now it won't even display any webpage from pinterest in the browser component.

I am guessing it has something to do with Content-Security-Policy on pinterest. I tested this on a MacOS 11.7 and 12.4 and both do not work. But, it does work on a MacOS 13.5

Is there some work around I can do to get pinterest to display in a TMSFNCWebBrowser on MacOS versions less than 13?

I tried changing the useragents and attempted to inject some javascript to force the page to display, but nothing worked.

thanks for any suggestions :grinning:

After research it seems that it's not possible to work around this. This is unfortunately beyond our scope. We'll monitor and see if anything pops up but at this moment it's unclear.

Thanks, I appreciate your efforts for looking into this. I'll continue to investigate as well.