3 questions :How to stop launch Browser


Is it possible to stop the launch of the browser when error appears in project ?
or only launch browser when there's no error.

How to keep all the time file list open (in explorer panel of VS).

Project won't toggle ide/designer anymore from a file why? All file toggle but not this.

When use XHR name for TWebHTTPRequest component application won't load data.

Thank you.

Many questions in one topic, would be better to split them.
Let's start with the first one:

  • When you get a compilation error in your project, this dialog is shown:
    It at some point you checked "remember my choice in user settings", you won't get the dialog anymore and that's why you are getting the browser, because at some point you decided to debug, even with errors in your code, and marked that option.
    In order to get back this behavior, search and change this option on Settings:

If this fixes your issue, then we can move forward to the next topic.

Did this answer solve your issue? If so, please, open a different post with a single question and I will help you. Thanks!

Hi Jose,
yes this solve my problem !
One question I move my project from my desktop to my laptop in same location for each.
But with my laptop TMS won't copy last js modified files located in a sub directory from project directory to Debug or Release directory. I need to quit VS remove TMSWeb dir to relaunch last modified file, can you help me ??

Sorry, but I don't fully understand the question. What I understand is:

  • In your project, apart from the .pas files, you have a subfolder with some .js files
  • You want that, when building your application, those .js files to be copied also to the TMSWeb folder created when the application is built
  • What is happening to you is that such folders are not copied, unless you quit VSC, remove TMSWeb folder, and then you build again

Please, let me know, thanks!

You are right.
I don't understand why .js files of a subfolder aren't copied in TMSWeb (Debug folder).

Hi Jose Leon Serna,
since 2 last versions, I need to reload VS code to launch appli after modification in CSS or JS files ?
Else VS code stop after compiling without error, without launch chrome ?!?!!
remark :
Since 2 the last updates of TMS Web Core, I needed to erase the TMSWeb dir content and restart the computer to obtain an application who will want run

When you say "Else VS code stop after compiling without error, without launch chrome ?!?!!" what do you mean that "VS code stop"?

And when you say "I needed to erase the TMSWeb dir content and restart the computer to obtain an application who will want run" what is actually happening? That is, what is the error you are getting or the behavior you are getting?


No VS Code don't stop, there's just an error in Terminal
"Cannot create file "x:\aReaCRM\TMSWeb\Debug\assets\js\util.js". Le processus ne peut pas acc�der au fichier car ce fichier est utilis� par un autre processus"

I de-install VSCode remove .vs directory,
re-install it with TMS Web Core and always the same issue.

Build complete.

The compilator say always the same thing when I modified a .js or .css file.
Can you help me ?


Hi, I found the problem it's my fault, I'm resuming an old version 3 days old and everything is ok. I think it's a bad command in an asm block.

you can close this


Hello again Jose,
In fact, the problem was solved when I went back to my desktop and used an older version of the API.
I worked for a week on the same desktop PC and had no problems.
I left my desktop and copied the API folder to my laptop, (this is the machine with issues)
I uninstalled VSC, TMS and Chrome and deleted all installation folders.
And again I have the same problem on this laptop.
When I edit a .pas or html file everything is fine, but when I edit a .js or .css file the first time I start debugging it compiles fine but the next ones I still get the same error.

Failed to create file "x:\aReaCRM\TMSWeb\Debug\assets\js\action.js". The process cannot access the file because this file is in use by another process

Building completed.

  • Termination of terminal process. Exit code: 1.

This looks to me some kind of antivirus issue, that is, it looks the compiler cannot overwrite some files because they are opened by another process.

@brunofierens what do you think?

Or is there a webserver running from where you started the app and this particular server is locking these files?