Unable to create a RELEASE version

For some reason I cannot create RELEASE versions (anymore) when selecting Run without debugging.

What is the error you get?

There is no error message. The app is compiled in debug mode.
Check the parameters:

Command line: c:\Users\henne002.vscode\extensions\tmssoftware.tmswebcore-0.0.3027\resources\compilers\tms\Win64\pas2js.exe ,-MDelphi,-l-,-JeJSON,-Jminclude,-Jmxssiheader-,-Jmabsolute,-O-,-Jc,-viw,-vnh,"-vm026,5024,3021,5023,4501",-Jitms.js,-Jirtl.js,-FUd:\Sources\Web_LVDSoorten\TMSWeb\Debug,-vb,-vl,-dDEBUG,-dPAS2JS,-dWEBLIB,-dWEBLIB,-dPAS2JS,"-Fud:\Sources\Web_LVDSoorten;\Core Source;\Core Source\RTL;c:\Users\henne002.vscode\extensions\tmssoftware.tmswebcore-0.0.3027\resources\coresource*;C:\Delphi\TMSSoftware\businessxe7\bcl\source\core\common;C:\Delphi\TMSSoftware\businessxe7\bcl\packages\web\pju;C:\Delphi\TMSSoftware\businessxe7\xdata\source\core\common;C:\Delphi\TMSSoftware\businessxe7\xdata\source\core\web;C:\Delphi\TMSSoftware\businessxe7\xdata\packages\web\pju;C:\Delphi\TMS WEB Core RSXE7","-Fi\Core Source;\Core Source\RTL;C:\Delphi\TMS WEB Core RSXE7;C:\Delphi\TMSSoftware\businessxe7\bcl\packages\web\pju;C:\Delphi\TMSSoftware\businessxe7\bcl\source\core\common;C:\Delphi\TMSSoftware\businessxe7\xdata\packages\web\pju;C:\Delphi\TMSSoftware\businessxe7\xdata\source\core\common;C:\Delphi\TMSSoftware\businessxe7\xdata\source\core\web;c:\Users\henne002.vscode\extensions\tmssoftware.tmswebcore-0.0.3027\resources\coresource*;d:\Sources\Web_LVDSoorten"

Is that a .dproj generated in RAD Studio or in VSC? Can you attach it? Just the .dproj.

Project1.dproj (34.4 KB)

Here is a project I created from scratch with VCS. Running without debug does not create a RELEASE version

I wonder if other users have the same experience.

I have not been able to reproduce and I see nothing wrong on your .dproj, so I keep investigating.

When you run your app, VSC sets the active configuration on the .dproj, and the compiler, based on that configuration, compiles the app, per your information, the IDE is not setting the release configuration properly.

Will let you know once I find something.

I installed TMS Web Core and VSC on a virtual machine and run into the same problem. No Release version cab be created. Am I the only one with this problem?
I also tried with older versions of VCS Tms Web Core, but that doesn't make a difference.

I just tried on a clean VM with Windows, and this is what I get when I use Run Without Debugging:

That is, a folder inside TMSWeb, called Release, with the output of the compiler. I'm still investigating, the last resort would be to allow me connect remotely to your VM to try find out what is going on. Will let you know.

Thanks for keeping providing feedback!

Obviously I only have the Debug folder.
No problem to allow you to connect to my computer.
Strange enough I was able to create a Release version a week ago or so.

I installed TWM Web Core on my wife computer and still facing the same problem with VSC. Very, very strange.

When I change "preLaunchTask": "Build" into "preLaunchTask": "Build Without Debugging" in launch.json I actually can build a RELEASE version. Obfuscation however, doesn't seem to be optimal, compared when building a release version with Delphi.
And when building with debugging the following error occurs.


It's not a solution of course, but maybe it can give a hint.

Please, mail me at jose.leon@tmssoftware.com with a schedule you are available so I can check your system remotely through TeamViewer.


I am available from 12:00 to 17:00 CET.


Thanks a lot for allowing me to access your computer, that did the trick! ;-)

Basically, is that VSC is a bit confusing, coming from RAD Studio, on how it handles build configurations, running and debugging.

In short, this shot shows the "selector" of the active configuration you want to run: DEBUG or RELEASE.

Run uses the DEBUG configuration, Run Without Debugging uses the RELEASE configuration.

So whenever you use the commands Start Debugging or Run Without Debugging from the Menu, first, it will build your project with the active configuration selected on the previous shot:


So the commands actually enable/disable the debugger, and the configurations actually enable/disable the debug information. So it may happen that you try to debug a release configuration, which won't produce debug information.

I hope it's clear, please, don't hesitate to ask for any additional information.

All clear now. Thank you too!