XData with ElevateDB error

I am creating an XData server with Aurelius and ElevateDB as the database. I finally got the XData database connection stuff working (hopefully correctly). I have a table called "Store" that contains restaurant info. When I tried to add the first record via my test client app I received the error:

XData server request error.
Status code: 500
Error Code: EDBError
ElevateDB Error #700 An error in the statement at line 2 and column 13 (Expected ) but instead found ID)

I'm not sure how to discover or fix the problem. I imagine there is an error in the SQL statement that Aurelius/XData created, but I can't see the statement and I didn't create the SQL statement. The "ID" mentioned in the error message is the first field in the Store table. It is a GUID and the primary key.

If this is not enough information I can supply the code.

We've used the sample project you supplied here: Index already exists - #7 by wlandgraf.
Unfortunately, we can't reproduce this issue. The server launches correctly, the client launches correctly, clicking the button "Add Store" doesn't raise any error. Is there something I missed in the process of reproducing the issue?

I ran it again, I get the same result. This time I traced it down so I could look at the SQL that was being run. This is what I found:

ID, Store ID, Active, Store Name, Date Created)
:p1, :p2, :p3, :p4, :p5)

Notice the fields "Store ID", "Store Name", "Date Created" do not have quotes around the field names. Could that be the problem? Also, maybe the fix you did for my "index" problem also fixed this?

I must be the only programmer in the world that uses spaces in field names.

In the test project I sent I just removed all spaces from the field name and indexes and everything works now. (I still want to use spaces, that way fields names used in code and what the user sees is identical and I don't have to be concerned with the presentation of field names in the UI).

I just noticed that there were updates available to the BIZ components that I had not installed. After installing them, I ran my test program again, You already fixed this problem. Sorry, I should have checked updates first before asking for help.

Thank you.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.