TWebTreeView and scrolling

Using latest version of TMS WebCore I have set up a webtreeview with 1855 records. Let me first say that the performance is excellent. Really fast.
There is only a problem with scrolling. When the treeview is larger that the window then a scrollbar appears and when scrolling down manually the cursor disappears. It the same problem I reported earlier with TWebDbGrid (which works as expected now).
Source code and json file to feed the tree are attached. (105.4 KB)

Two other issues related to TWebTreeView.

  1. Setting AutoExpand to true does not expand the node and all underlaying children.

  2. I want to activate a specific node in the tree using the code WebTreeview.Selected := WebTreeview.Items[400]. Nothing happens. Wrong coding?

WebTreeview.Items[400].Selected := True doesn't compile.

Another issue is that at the lowest level in the tree the items cannot be selected with the mouse. Selection works using up and down keys.

  1. I'm not sure what you mean exactly with "scrolling down manually the cursor disappears"? I could not see an issue here. You refer to the mouse pointer or something different?
  2. We have seen & fixed the issue with selection on lowest level (has actually nothing to do with lowest level but fact that you inserted HTML formatted text.
  3. We have fixed the issue with AutoExpand
  4. To select a node programmatically, we tested WebTreeView.Selected := yournode and this worked as expected.
  1. you have to expand the tree in such a way that the tree is larger then the window. To see the lowest part of the tree you can either use the scrollbar (with mouse), or use the keyboard to scroll down in the tree. In the latter case the cursor disappears when getting at the bottom of the window. The cursor disappears and the tree remains static.
  2. Nice. But nodes at higher level with html code do not show this behaviour.
  3. Excellent
  4. WebTreeView.Selected := yournode I would expect that the tree expends and shows the requested node. It doesn't work in my case. (108.3 KB)
I have posted the tree test once more, now with a button to select a node.
Nodes are stored in a TObjectList.
In the button click event just one line of code WebTreeView.Selected := FNodes[400];
Nothing happens when I click the button. Any suggestion what's wrong?

You test with v1.6.0.1?

Yes, v1.6.0.1

I have got the demo working now after I disconnected the computer from the cable and switch to WIFI. My own application still not working (it has been working for several months).

If a problem persists, please isolate & provide a sample source project + clear steps to reproduce.

The problem is solved. It was a server side issue. Sorry for having wasted your time.