Twebdbtablecontrol fit to screen

Hi see the image : how to fit the grid on the screen setting the word wrap on the column (with red hand write). ElementClassName of the column is "col-md-auto w-100 generic-font fw-bold" with bootstrap 5.



Grids can be tricky to style. So many things can go wrong! Fortunately the defaults work most of the time, but getting everything perfect is sometimes quite a challenge.

For the text in the column, you can try and add the bootstrap class text-wrap and see if that works for you. I think this translates to the equivalent CSS of white-space: normal. This may have undesired results if the row height doesn't automatically increase to accommodate the extra line though, so something to keep in mind. Hopefully it works without issue.

Getting the grid to fit the screen so that you don't have a scrollbar at the bottom is likely a ompletely separate issue. Lots of ways to get rid of that scrollbar and have the grid better. Some things to try.

  • Try setting the align property of the grid control to alCenter along with any of its parent controls so that it fills up the form.
  • Try adding w-100 to whatever you are using for a grid control.
  • Try adjusting the width-related properties of the grid control. For example WidthPercent to 100 and WidthStyle to either Percent or Absolute.

Sometimes this is a bit challenging as it may have nothing to do with the grid if the grid is within another control. You then ave to look at that parent control's properties and make changes there.

Hi andrew "text-wrap" go fine but for this vertical scroll bar was hide. With Option->Scrollvertical solved problem !

Thank you