TTMSFNCRichEditor and InsertAsRTF (occultism in my PC)

I'm starting to doubt myself.
Until yesterday I was able to load my old RTF texts without any problems.
And today I suddenly get exceptions.

This text worked perfectly yesterday

  s := '{\rtf1\ansi\ansicpg1252\deff0\deflang1031{\fonttbl{\f0\fnil\'+
       'fcharset0 MS Sans Serif;}}{\colortbl ;\red255\green0\blue0;}'+
       '\viewkind4\uc1\pard\f0\fs24 Nachtrag: P\''e4ckchen ist angekommen }';
  TMSFNCRichEditor.InsertAsRTF( s);

If I change the \'e4 (= ä) to a everything works.

\'e4 original RTF
\''e4 in Delphi with double '
this is not the reason

An today I get this exception (see picture)

If I change the word to "Packchen" instead of "Päckchen", it works.

In the stack you see OmniThreadLibrary. The code is in the "AWait" section and runs in the mainthread.

And I don't found any object is nil

I have found the problem.

I am using the OnChangeEvent.
And in the event I accessed RichEdit.ContentAsRTF.
That triggered the error.
Previously, I had only accessed RichEdit.Text. That worked without any problems.

The solution: I disable the event while I'm loading the text from the database.