TTMSFNCNavigationPanel not working at runtime

Win10 / VSC 1.58 / WebCore & FNC UI pack latest versions

I tested this with the project types PWA and Miletus. When adding a TTMSFNCNavigationPanel control the application can't compile

Error: identifier not found "pcNone"

I figured out, that I need to add unit WEBLib.TMSFNCPanel.

Anyway, when starting the app, the control is not rendered properly and there is no functionality.

I cannot reproduce a problem.
I also retested our FNC Navigation Panel demo that comes with TMS WEB Core and this demo also works as expected.

Is there any javascript error in the browser console?

Not that I noticed. Is this output telling you something? (Running on Win10 in a PWA)

I just can try to describe the control behaviour when placing it onto an empty webform. Its looking pretty normal. In the source code this creates these objects:

  TForm1 = class(TWebForm)
    TMSFNCNavigationPanel1: TTMSFNCNavigationPanel;
    TMSFNCNavigationPanel1Panel0: TTMSFNCNavigationPanelContainer;
    TMSFNCNavigationPanel1Panel1: TTMSFNCNavigationPanelContainer;
    TMSFNCNavigationPanel1Panel2: TTMSFNCNavigationPanelContainer;
    { Private declarations }
    { Public declarations }

When selecting one of the PanelNavigationContainer, they all have negative heights and a width of 0

I'm still trying to make this control work. I installed all latest versions of TMSWEBCore VSC / TMSFNC UI Pack. Which demo are you refering to?

This demos, I guess, are created by delphi RAD Studio. Did you try to create a new PWA/Electron App/ Miletus app from scratch with TMSWEBCore for VSC, using the TMSFNCNavigationPanel control? Its showing the control properly during design time, but not at runtime.

Best regards

I'm referring to the demo under Demo\FNC\NavigationPanel (69.2 KB)

Ok, my fault. I was searching in the FNC UI Pack demos. I apologize.

I tried the demo, and yes its running. When open the demo in VSC, a message shows up:


When trying to open the property editor for property Panels a crash report shows up:

The source unit Unit1.pas is containing the VCL.TMSFNC* declarations, because the demo is created in the delphi IDE. Can you pls. try to create a WEB app with an empty WEB Form in VSC and place a TMSFNCNavigationPanel onto it, and run the app?

Seems, the three TTMSFNCNavigationPanelContainer which are generated automatically when placing the TTMSFNCNavigationPanel onto the form, are causing some trouble. When I remove them, clear the TTMSFNCNavigationPanel Panels property in the form constructor, and add panels by code, all seems to be running fine.

We have meanwhile fixed the Margins issue when opening and running the demo. We'll investigate the issue with the panels added at designtime

Latest TMSWEBCore VSC 1.9.5316

When open the FNCNavigationPanel demo this message shows up:


This seems to be a problem with the control for projects that were created in Delphi and are openend in VSC.
We will look into this to fix this, but for the moment the issue can be solved by removing the OldWith property from the dfm.