TTMSFMXWebGMaps blank gap at top

Hi, I'm using the WebGMaps component on a panel and aligning the component to client.  What I'm seeing is a small blank gap at the top of the panel - it's about 20 pixels high.

I'm tried switching to content alignment and the result is the same.  I tried the component on a blank form and found the same issue.  There's always a small gap at the top of the container object.

Not sure what I'm missing here, might be something related to the map options.  Has anyone seen this before and solved the problem?

FYI I've also tried placing the TMSFMXWebGMap control on a blank form.  The blank gap is still visible at the top of the form.

As an experiment I added this code to a button onclick event:

  TMSFMXWebGMaps1.Visible := True;
  TMSFMXWebGMaps1.Position.X := 0;
  TMSFMXWebGMaps1.Position.Y := -20;

The map still shows at the position about 20 pixels down from the top of the form.
I'm thinking that I'm simply missing some small option or feature.  Any ideas?


We are currently implementing a new technique so the next release should fix this issue.

Kind Regards, 

What is the timeline of the next release and the fix for this bug? 

Are there any known workarounds for the TMSFMXWebGMaps positioning bug?

Without unexpected issues, the new release will be this week.

Hi, can I ask about the status of this bug fix?

Where can I find the version updates information?

I've updated to version 1.8 of WebGMaps and found that the positioning is working properly now.

However there's a new problem with this version.

In managing the visibility of the component I find that I can set the initial map.visible property to false.  And then I can programmatically turn the visibility on using map.visible := true;

However when I try to turn the visibility off using map.visible := false this doesn't work.  I'm unable to hide the map control once it is visible.

So basically TMSFMXWebGMaps.Visible := False doesn't work.


We have tested this here and are not able to reproduce this.
Please send us a sample that is able to reproduce this so we can investigate this here.

Kind Regards, 

Here's a quick little app that tests the map.visible property.

Click the Map button to open a new form with map - THeaderFooterwithNavigation.SpeedButton1Click.
Click the Close Map button to close the map and return to the first form - TForm1.Button1.

On my test device the map doesn't close with I click the Close Map button - TForm1.Button1.

procedure THeaderFooterwithNavigation.SpeedButton1Click(Sender: TObject);
  Form1.TMSFMXWebGMaps1.Visible := True;


procedure TForm1.Button1Click(Sender: TObject);
  TMSFMXWebGMaps1.Visible := False;

I can post the whole project if needed.

FYI I'm using Delphi XE6 and TMSFMXWebGMaps 1.8

I'm compiling the Android demo app and adding a button to the Options page.  All the button does is:

TMXFMXWebGMaps1.Visible := False;

But the map does not get hidden.

BTW - maybe this is a clue.  When I compile the app I get an error on the line to include FMX.Sensors

[DCC Fatal Error] UWebGMapsDemo.pas(9): F1026 File not found: 'C:\Users\Public\Documents\tmssoftware\TMS WebGMaps for FireMonkey Demos\Android\FMX.Sensors.dcu'

When I remove the include for FMX.Sensors the compile works.

Can you confirm that my configuration should work?


The reason we were not able to reproduce this is because we have tested this on iOS. The 20 pixel border issue is something that is related to the iOS 7 statusbar. It wasn't clear until your last post that you were working on Android. 

On Android we were able to reproduce this and have applied a fix, the next version ( will address this.

The demo is created in XE4 for compatibility with XE5 / XE6. The FMX.Sensors is a unit that no longer exists in XE6. We have removed the unit as it is not necessary for correct compilation.