TMSFNCWXCamera/Barcode no funtion/black screen under Android 12 API 33.0.3, Alexandria 11.2

Hi folks,

the demo of the camera have no function, only black screen under Android.
it looks like a really awesome product. But if the demo doens't work already, it's a knockout reason !!!

Delphi 11.2
SDK 33.0.3
Android 64 Android V. 12


Best regards Borni !!!


You mention you are trying to use the demo. It could be the demo was created with a different IDE version than yours. Have you tried the "Revert System Files to Default" option? Don't forget you'll need to add the necessary JAR files after doing that.

To add the JAR files, you can follow this guide:

Alternatively to track down this issue: does this also happen if you drop the component in a new project and add the necessary JAR files to the project? Do you see any error messages?

this is the same problem also with the original jar-files settings.
i've reinstall delphi 11.2 Patch 1 with the original sdk for android, it's the same error.

Even the subsequent granting of all rights has brought nothing.

it's seem to be a problem with alexandria 11.2 patch1 ? NO ERROR MESSAGES (black screen)

best regards

We also have 11.2 installed with patch 1, so that is probably not the issue.

Can you try to check what happens if you force the FileLocation to online?

procedure TForm1.FormCreate(Sender: TObject);
  TMSFNCWXCamera1.FileLocation := cflOnline;

Alternatively if that does not work you can try to debug the underlying browser that hosts the camera:

  1. Have the application running while it is connected to your computer.
  2. From Chrome (or Edge) go to chrome://inspect (or edge://inspect) and wait until the application shows up in the "Remote Target" section
  3. Once it shows up, you can inspect the browser that hosts the camera. Check the console tab to see if there are any error messages.

, I had to add two files to the Libraries folder, for this package on my 11.2 install, as it was located in my "C:\Users{your-computer-name}\AppData\Local\tmssoftware\trial\TMSFNCWXPack {RSXE7}\Android Support" folder,

and locate and add the following two files into the Libraries section in your IDE:

  • JavaScriptHelper.jar

  • FNCWebChromeClient.jar

and now it runs!!

I will test your solution now !