Good morning,

i create a webapp with tms xdata and tms web core which runs on an amazon ec2 windows server. I can access it via IP and already linked the domain to it (works fine as well via http).

Now i wanted to change it to SSL, i opened the ports on amazon ec2, created the lets encrypt certificate which i added in http sysconfig and changed my Server and WebUrls to https://+:443/data/webclient ... (/xdata).

When i now try to connect via IP or domain i get a timeout which i cant spin my head around. any idea what im doing wrong?

thanks in advance

Does it work if you use a different port? Maybe try something much higher like 23456 or something outside of 0-1024.

sadly no.

i changed the Servers Base Url to https://+:23456/Data/xdata and the Static Dispatcher to https://+:23456/data/webclient which i assume, is correct..?

thanks and best

And you're attempting to access this locally or remotely? Other things to (re)check.... The HTTP Config Tool, firewall settings (if testing remote access). First thing would be to test with browser locally. Rules out so many other things.

i can call it on my localhost.


showing my SSL certificate failure obviously.

but remote does not work. My base URLs are correct, right?

on aws this is my ports

and httpsys also has the access to the port

Have you also allowed the port on the Windows firewall?

thank you. i missed that. now it works with IP.

can you push me into the direction on how to get my ec2 webserver application to be accessible through SSL with domain? i already pointed the domain to to aws, setup target groups and a routing with E53, but it wont work.

thanks in advance once more.

ok, finally got it running, seems i overcomplicated things..
the only issue i now face is that when i interact and call procedures on my site.

so for example i call my domain in SSL mode and it displays safe, but when i click a button which executes a query the site/certificate shows invalid...?

okay, found that too.. had to change the URL for my Webclient to my domainname.. now it works.

thanks for both of your help!

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.