When I build TMS IW the IW14tmssedxe5upd.proj giving an error when building saying that "file not found" for classes.dcu.   All of the others compile file.

Any thoughts?


IWScriptEdit.pas(15): error F1026: File not found:


Can you please make sure "WinApi" and "System.Win" have been added to the unit scope names?

- Right click the project file in the project manager and select "Options"
- Select "Delphi Compiler" in the pane on the left side
- Make sure "WinApi" and "System.Win" are present in the Unit Scope Names field

Those items are present.

Please make sure to set your Delphi library path correct that it includes the folder where these DCU files are located. The library path can be configured under menu Tools, Options, Library - Win32

Release October 2013 : version v5.4.0.0 builds fine.

But when I put version v5.5.0.0 in place it fails.  Here is the exact error.

C:\Users\Public\Documents\RAD Studio\DIAComponents\TMS\TMSIntrawebProIW14XE5>msb
uild IW14TMSSEDXE5UPD.dproj
Microsoft (R) Build Engine Version 3.5.30729.5420
[Microsoft .NET Framework, Version 2.0.50727.5477]
Copyright (C) Microsoft Corporation 2007. All rights reserved.

Build started 7/1/2014 12:43:55 PM.
Project "C:\Users\Public\Documents\RAD Studio\DIAComponents\TMS\TMSIntrawebProI
W14XE5\IW14TMSSEDXE5UPD.dproj" on node 0 (default targets).
  Embarcadero Delphi for Win32 compiler version 26.0
  Copyright (c) 1983,2013 Embarcadero Technologies, Inc.
IWScriptEdit.pas(15): error F1026: File not found: 'C:\Users\alnoland\AppData\R
oaming\IntraWeb XIV\CrossTalk\XE5\Classes.dcu'
Done Building Project "C:\Users\Public\Documents\RAD Studio\DIAComponents\TMS\T
MSIntrawebProIW14XE5\IW14TMSSEDXE5UPD.dproj" (default targets) -- FAILED.


"C:\Users\Public\Documents\RAD Studio\DIAComponents\TMS\TMSIntrawebProIW14XE5\I
W14TMSSEDXE5UPD.dproj" (default target) (1) ->
(_PasCoreCompile target) ->
  IWScriptEdit.pas(15): error F1026: File not found: 'C:\Users\alnoland\AppData
\Roaming\IntraWeb XIV\CrossTalk\XE5\Classes.dcu'

    0 Warning(s)
    1 Error(s)

Time Elapsed 00:00:00.72
build complete

RAD Studio XE5 Enterprise v19.0.14356.6604
Intraweb 14.0.32

I'm not sure why it is looking for classes.dcu in the crosstalk directory unless that is the last place it searched.  

I wouldn't even need to upgrade but I have found an issue with the tadvtreeview where the click event stops sending the correct node information if the hint has a '/' in it.  I was hoping it was fixed in the new version.

I found where I had downloaded release December 2013 : version v5.4.0.2.  I tried to build it and I get the same error.

I copied the .PROJ file from the version that works to the new version 5.5 directory.  I was able to build it.  It seesm the .proj file for that package didn't have any default build platforms defined.  I did a compare of the new and old and discovered lots of missing information in the 5.5 package.  

- I have not been able to reproduce an issue with the IW14TMSSEDXE5UPD package.
I'll have to investigate what could be going wrong.

- The issue with hints that have a '/' character has indeed been fixed in the latest version of the TTIWAdvTreeView control.

After updating I'm still having issues with the TIWAdvTreeView ItemClick click event.  The node parameter will send the correct node reference a few times, but eventually it will get stuck and send the same node reference no matter which node I click on.  

I have not been able to reproduce an issue with the OnItemClick event.

Can you please explain exactly how to reproduce the issue so I can further investigate this?
Please also let me know which version of IntraWeb and which browser you are using.