TMS iCL Demos

Using Delphi Berlin 10.1.2 with iOS SDK. 

TMS iCL Demos for Camera and MontionManager (the two I tried) do not compile. Problem seems to be looking for a PrivateFrameworks directory that does not show in my SDK installation.

Here is the error:
DCC Error] E2597 ld: warning: directory not found for option '-FC:\Users\Eduardo\Documents\Embarcadero\Studio\SDKs\iPhoneOS10.0.sdk\System\Library\PrivateFrameworks'
  ld: file not found: /System/Library/Frameworks/CoreMotion.framework/CoreMotion
There is a  C:\Users\Eduardo\Documents\Embarcadero\Studio\SDKs\iPhoneOS10.0.sdk\System\Library\Frameworks'  
Yet within it, there is no /System/Library/Frameworks/CoreMotion.framework/CoreMotion

Hope this helps



You need to add this framework to your SDK manager and update the local cache in order to be able to succesfully link the application. More information on how to add the necessary frameworks is found in the documentation on page 187
Guess I have to read the PDF all the way. :-(


Hello, i am running into the same problem.
I dont understand how to add a framework.
When i try to add it doesnt show me anything.
I am working with Delphi 11

ok, i found it. It was complex because manual looks different and my delphi is in german language. In german it is the Button on the right side with "add new path"

1 Like

Hello, same problem.
Delphi 11.3 with ICL v., SDK 16.2
[DCC Fehler] E2597 ld: file not found: /System/Library/Frameworks/CoreMotion.framework/CoreMotion

I have added to the SDK manager
CoreMotion with path $(SDKROOT)/System/Library/Frameworks
and after that I Click on “Update local file cache” .

compile in Delphi - same error.

Under windows path
C:\Users\NAmeXX\Documents\Embarcadero\Studio\SDKs\iPhoneOS16.2.sdk\System\Library\Frameworks is no directory CoreMotion.framework

What is the problem?

You are sure that the type is set as 'Framework' when you create a new one?
And that you click save after adding and updateing the local file cash?

As normally this should add the folder.

I've found the problem. My mistake.
in path:
correct: $(SDKROOT)/System/Library/Frameworks
I wrote: