RemoveRows(1,1) deletes last row

AdvStringGrid 7.2.9.1 / Delphi XE3



RemoveRows(1,1) removes Row with index 1, but also the last Row gets invisible.

When calling RemoveRows(1,1) a second time everything seems to work fine.



Also strange: When calling AddRow after RemoveRows(1,1) the first time, the last row gets visible again !?



Re-Installation of Component-pack did not help.

Tested it also on a clean Delphi+TMS Installation on a second machine. Same issue...



Does anyone else see this strange behaviour ?



RemoveRowsEx(1,1) seems not to have this behaviour. BTW - couldn't find RemoveRowsEx in Developers Guide. What is the difference ?



Thanks !

Could anyone please do a quick check if this behavour is reproduceable ?



Just throw a TAdvStringGrid and a TButton on a Form and call AdvStringGrid1.RemoveRows(1,1).



Count the Rows of the Grid on Form-Create and after pressing the button.



On my machine 2 Rows disappear !?!



Thanks, Tom

We have traced & solved this issue. We'll release an update on Jan 14 that will address this.

If you need an urgent fix, please contact us via help@tmssoftware.com

Just for the records - the fix worked fine - issue closed.



Thanks Nancy !