Missing files

XE2, Intraweb 14.0.52 (but also tried Intraweb 14.0.51), lastest IW Component Pack Pro

Intraweb installed correctly - compiled and ran Features demo.

Followed the instructions in the install.txt. 
IW14TMSDXE2.dproj compiled and installed 
The next one (IW14TMSDEDXE2.dproj) gives the error: IWTMSDEREG.pas(26): F1026 File not found: 'IWRenderStream.dcu'.
I have tried using both the MSBuild and opening with the IDE options. Both stop on the same error.

I have searched the entire Intraweb / TMS IW component folders and that file doesn't exist. Where do I get it from?


As instructed in INSTALL.TXT, for updated IntraWeb versions, you need to use package IW14TMSDXE2UPD.DPROJ / IW14TMSDEDXE2UPD.dproj

Hi Bruno

From the install.txt:
"  IntraWeb 14.0.x / RAD Studio XE3 - 10 Seattle

   msbuild IW14TMSDxxUPD.dproj
   msbuild IW14TMSDEDxxUPD.dproj
   msbuild IW14TMSGRIDDxxUPD.dproj
   msbuild IW14TMSGRIDDEDxxUPD.dproj
   msbuild IW14TMSXLSDxxUPD.dproj"

It says XE3 - 10. Not XE2!

Plus there is no IW14TMSDXE2UPD.dproj etc.


The IW14TMSDEDXE2.dproj file is the correct package to use for Delphi XE2 with IW 14.
I have retested the packages here and haven't noticed any issues.

Can you please try to remove all files related to the TMS IntraWeb Component Pack and try installing again?
Also make sure you are using the correct tmsdefs.inc file.
For IW 14, remove any existing tmsdefs.inc file and rename tmsdefs140.inc to tmsdefs.inc.

Found the problem. And in case it helps anyone else ... the error was due the Intraweb uninstall not removing the IntraWeb_14_DXE2.dcp file from the ... Public\Documents\RAD Studio\9.0.Dcp folder.