MiletusMySqlDBDriver on Linux

Hello. Ive built small application on TMS WEB Core, which connects to MySQL database and edits some data in it. It works perfectly fine on windows, but when trying to run it on linux, i am getting error "[FireDAC][Phys][MySQL]-314. Cannot load vendor library [, libmariadb or]. Hint: check it is in the PATH or application EXE directories, and has x64 bitness. Trying to run application on X64 Ubuntu, and ran out of ideas what to try to fix this error.


Have you installed the MySQL library on your Ubuntu? Which one? Where is the .so currently located?

Hello. I currently have "mysql Ver 15.1 Distrib 10.3.34-MariaDB" installed.
For .so files:
"./mariadb-10.7.3-linux-systemd-x86_64/lib/" not found
Should mention that i personally dont use linux and dont know how to properly use it, so sorry if i did something wrong.

That does not seem like it's in a system path (or next to the executable), is that correct? Try to create a symlink?

sudo ln -s /usr/lib/x86_64-linux-gnu/

No idea if its system path (As mentioned, i have no clue with linux), but its certainly not next to executable. Tried running the provided command, sadly no luck, still getting same exact error when trying to run executable

Ok, just tried randomly copying the nessecerry files and placing them next to the executable - now it tries to start, sadly comes up with an error "unsupported MySQL version [302060000]. supported are client and server from v 3.20. No idea if this is client side (from the files i copied) or server itself im trying to connect to is outdated, will try to investigate this :slightly_smiling_face:

EDIT: Seems to be client side error or some kind of compatibility issue, just installed newest possibly mysql server and yet getting the same exact error, even though mysql server is now version 10.4.

How did you install your server and client?

Sorry for late response but i just not realized i left this all hanging without any answer.. ive installed MySQL client using command " sudo apt-get install mysql-client ", for server - trying to connect to database outside of the machine, also tried to create database using xampp just to be sure, but still no luck. For now im waiting for new machine to arrive on which the actual software im making will be running, so i can properly test it on actual software/hardware which will be used.


Not sure which Linux distribution are you using. We did our development and tests on Ubuntu with the libmysqlclient21 library. Are you limited to the mysql-client library?