"map" not defined


I am using the latest version of WebGMaps and I face a non critical issue.

When I start my application I call the WebGMaps.Launch procedure which takes a few seconds to load the map completely. During this time a user can open a file for my application where I load markers on the map. In that case I get an error message about "map" not defined (I actually get this in my native language so I am not sure if I translate that correctly). I was wandering if there is a way to know that the map is successfully loaded and ready to accept data.

I hope I described my issue well enough.



You can use the OnDownloadFinish event to know if the map has finished loading.

Thank you very much for your reply :)

Hello, on this matter I know face a a problem.

I added this line: 

procedure TMainForm.WebGMaps1DownloadFinish(Sender: TObject);
MessageBoxEx(handle, 'Map succesfully loaded',  'Message', mb_ok, lang_neutral);

I have placed the WebGMaps component inside the tab of an AdvOfficePage. This tab is not the active tab. When I run the app from within the IDE under 8.1 I see the message ok. If I run my application on my laptop under Windows 7 the message does not appear, I have to select the tab with the WebGMap component in order to see the message. How can I force the map to load regardless if it is visible or not?


Please note it is required that TWebGMaps component is visible for the OnDownloadFinish event to work correctly.
This is a limitation of the TWebBrowser component which we have no control over.


I think calling the WebGMaps.WebBrowser.HandleNeeded method before the WebGMaps.Launch forces the page to be loaded although the component is not visible

That is a possible workaround.

Hello Bruno,

Yes, it works fine, at least for me!