is it possible in any way to configure TTMSFNCBrowser with some flags?

I have a web app that I'm trying to make a native wrapper for.

on the browser I can load a meeting and have a talk using webrtc.

but once I try the same on the wrapped component some of websocket calls does not return and stay pending response.

is there any way I can set some flags or change some properties to allow these calls to return?



If you designed your application with TMS WEB Core, there is a separate TTMSFNCWebCoreClientBrowser component for that purpose. It will setup a handshake and then allow you to communicate with the webclientsocket server and client. If your web application is developed outside TMS WEB Core, we'll need more information on what exactly you want to achieve when using the TTMSFNCWebBrowser. Which flags are you referring to exactly?

It is a react app

the app is trying to connect to the backend via websocket,

if I run it on edge, chrome or any supported browser the websocket call returns,
but if I try to load the same app in the TTMSFNCWebBrowser those calls get stuck and never return,
when I look them in the console window I see they are still pending for response.
My backend does not care who is calling (I tried a native websocket control to see if the call returns and that is working).

I think it is some permission I'm not setting for the control or some thing else.

Hi, we found a few issues regarding websocket support in the embedded chromium webview 2 control:

It basically tells there is a security issue when using custom URL schemes other than HTTP & HTTPS. Can you perhaps try to capture the exception or error? Do you actually get a connection in the backend and then hangs or is it hanging inside the client?


the thing is, it is never hanging just stuck and pending the response.
I will see the back end side to confirm. but on the client side nothing just stuck and waiting.

and we have no errors on client side.


If we could have some sort of test page or sample, which is able to reproduce this, please let us know.

Hello I just checked connect to

look at dev tools the call to connect is pending.

delphi 10.4.1 with all patches
FNC core latest version
edge runtime 88.0.705.62

We found the problem, it was a hidden param in the call to the websocket in win platform. we are still investigating the macOS build and why we can not access.

I will update this post for future readers.

Thankyou very much


Thank you for confirming. Please let us know if you have further issues.

We still have this Javascript bridge error on set method from JS
which we are waiting for further response, but other than that I will make sure to update you.


I answered in this thread that the code is working on our systems. I suggested to gradually build up the code again until you get the error.

Okay thank you very much we are doing that as you asked.

Thank you very much for your response. and have a nice weekend :smile:

1 Like