identifier not found "TCustomWebLookupComboBox"

I am getting this error when calling (sender as TCustomWebLookupComboBox) .I have WEBLib.ExtCtrls in the interface uses clause. Any ideas?

Where is this declared?
I'm not finding this class anywhere in TMS WEB Core\Core Source folder?

so I see

TWebDBLookupComboBox = class(TCustomWebLookupComboBox)

and then

TCustomWebLookupComboBox = class(TCustomComboBox)

I can only think this is old code as this isn't in the latest version source code.

I'll try upgrading. Date on WEBLib.ExtCtrls is 19-Dec-2021

Even so, strange that it can't be found

I've redownloaded and reinstalled WebCore - uninstalled, deleted the folders, used a different folder name - and it is still the same code as described above.

Are you really looking into the latest version \Core Source folder?
I checked the version control system here and at least in the last 6 months, I can't find a reference to TCustomWebLookupComboBox

I was looking around at another TWebLookupComboBox issue, so I tried this grep, if it helps. Latest version of TMS Web Core as well, so far as I'm aware.

...tmssoftware\registered\TMS WEB Core RSXE12>grep -i -d tcustomweblookupcombo *.pas

Component Library Source\WEBLib.DBCtrls.pas
  TWebDBLookupComboBox = class(TCustomWebLookupComboBox)
Component Library Source\WEBLib.ExtCtrls.pas
  TCustomWebLookupComboBox = class(TCustomComboBox)
  TWebLookupComboBox = class(TCustomWebLookupComboBox)
{ TCustomWebLookupComboBox }
constructor TCustomWebLookupComboBox.Create(AOwner: TComponent);
destructor TCustomWebLookupComboBox.Destroy;
function TCustomWebLookupComboBox.GetDisplayText: string;
function TCustomWebLookupComboBox.GetHeightEx: integer;
function TCustomWebLookupComboBox.GetValue: string;
procedure TCustomWebLookupComboBox.SetDisplayText(const Value: string);
procedure TCustomWebLookupComboBox.SetHeightEx(const Value: integer);
procedure TCustomWebLookupComboBox.SetHeightPercent(const Value: TPercentSize);
procedure TCustomWebLookupComboBox.SetHeightStyle(const Value: TSizeStyle);
procedure TCustomWebLookupComboBox.SetLookupValues(const Value: TLookupValues);
procedure TCustomWebLookupComboBox.SetValue(const Value: string);
procedure TCustomWebLookupComboBox.SetWidthPercent(const Value: TPercentSize);
procedure TCustomWebLookupComboBox.SetWidthStyle(const Value: TSizeStyle);

It's in Component Library Source, which must be what is looked up in the IDE and why it shows as missing when compiling - indeed the structure in Core is very different.

I checked deeper and it was a mismatch between the design-time & run-time code.
It will be fixed in the next update.
For now, just cast in the code to TCustomLookupComboBox

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.