grid + livebinding + clientdataset : wrong record

When livebinding a clientdataset with a tmsfmxGrid. And you select a row in the grid, this does not match the row in the dataset.

this depends on the number of fixed rows (default 1) so the deffault difference would be 1.
for ex:  If you have 2 fixed rows, the selected row in the dataset is the selected line in the grid + 2

Filip

We are aware of issue in LiveBindings in XE4, unfortunately there hasn't been found a solution yet.

There are also some other issues that need to be taken care off but due to the current high workload we haven't been able to allocate time for this.

Kind Regards, 
Pieter

before open the dataset set dataset DisableControl after open set dataset set EnableControl. we solve that issue like that :)

[code begin]
ClientDataset1.DisableControls;
ClientDataset1.Open;
ClientDataset1.EnableControls;
[code end]

Hi, 


Thank you for the input, we will investigate here if that is indeed the case when editing a field as well.

Kind Regards, 
Pieter

Thank you for this, I am going through the nightmare of taking (fortunately) a relatively simple XE3 app to XE4 when I spotted this one! Your fix has worked for me although I still remain nervous about FireMonkey when put against straight VCL apps. 

Unfortunately XE3 is as good as incompatible with XE4 so it is best to start with a new project.


Kind Regards, 
Pieter

Everything is working apart from this grid issue (the outlined "fix" is only partially successful). As you are not committing to a fix I will dump the TMS grid for the default as this does not have this issue.

I have just tried using a string grid as a temporary fix to this issue but it looks like the grid in XE4 is far from perfect. Although the problem is slightly different if you display one row, update the result set to zero rows the displayed row does not get updated (in stays visible).


I'm sure the issue is more complex than my brief description but there is a problem! I am getting tired of being a bug hunter for Embarcadero especially as I pay for the upgrades!

How can anyone, I include TMS in this, get working products out to the customer in such situations? My customers now have a choice, live with the bugs we know about in XE3 or look at incorrect data in XE4, not even tried to run this in OSX yet.

Time for a beer I think! 

We updated our project to XE4, so we could work with updated tms components. tms components for XE3 had bugs, but at least you could work around them. Now its just an unworkable mess.

Why do they bring out new XE version every year, when there not even compatible...