FMXSignatureCapture android producing blank images

Hi, we've emailed TMS support but have as of yet not got a reply so we're reaching out to the community.

We're using the FMXSignatureCapture in an app and producing .sig and .png files from it. This works fine on iOS and Windows but on Android the .png file produced is valid but blank, the .sig file is ok.

We have tried producing .bmp instead but that errors. We have tried producing .jpg but that also produces a blank file.

This is the code we are using:

        fname := TGuid.NewGuid.ToString;

{$IF Defined(ANDROID) or Defined(IOS)}

        localPathFilename :=
TPath.Combine(TPath.GetDocumentsPath, 'images' + PathDelim + fname + '.png');

        localSigFilePathFilename :=
TPath.Combine(TPath.GetDocumentsPath, 'images' + PathDelim + fname + '.sig');


        localPathFilename :=
TPath.Combine(ExtractFileDir(ParamStr(0)), 'images' + PathDelim + fname +

        localSigFilePathFilename :=
TPath.Combine(ExtractFileDir(ParamStr(0)), 'images' + PathDelim + fname +




To replicate add a FMXSignatureComponent, sign and run the above code.


I can create an FMX app to generate the images post process, but how do i resize my signature component to match the .sig file? If I don't I'll end up with some of the signature missing...



Have you tried saving it to a different folder? For example the TPath.GetSharedDocumentsPath?
Alternatively, try loading the signature image inside a TImage after saving it to see what happens?