Data modeler gives an EGUIException when reading AppMetaData.DiagramObj.Diagrams

I have tested the Data Modeler trial and today I installed the registered version. When opening it for the first time I got an Application Error saying: "Exception EGUIException in module dm.exe at 00625345. The file 'northwind.dgp' is not a valid Data Modeler project file. Internal error: Error reading AppMetaData.DiagramObj.Diagrams: Access violation at address 00000000 in module 'dm.exe'. Read of address 00000000." and after that it closed.
It was trying to read the sample file that was just installed. I renamed the file and it opened. I created a connection from the menu and when trying to create a new project, what ever database I create/use, the Data Modeler gives an "Access violation at address 00000000 in module 'dm.exe'. Read of address 00000000." without any other information and does not create/open any project.
I have sent an email to support, and I provided the info they requested.
In the mean time, does anyone else arrived to the above situation? If so, did you find a solution?
Thanks in advance

Hi Dimitris,
We have been talking about it via e-mail, but since you open the ticket here, we can continue in this topic.
As I said, I have never seen such issue before, and if someone here can share their experience, that would be valuable of course.
Have you tried by chance to install Data Modeler in a different computer, and/or different folder?

I tried to uninstall it and reinstall it again. Nothing changed. I have to say again that a couple of months ago I have used the trial of Modeler that worked without problems.
I tried to install it in a fresh installation of windows 10 with only greek language and it worked. The problem is, that I need to make it working in the computer I need, not in a computer I do not need.
I am not now running any antivirus program except windows Defender. I tried to disable anything in windows defender and the problem persists. I tried to run it after a reboot without opening other programs and it still exists. I have sent to you through email screenshots from task manager with all processes running.
I have uninstall it and installed again data modeler trial. It is installed but it does not work due to date restriction (I have installed it 2 months ago for the first time)
I uninstalled the trial and I installed again the registered version in a different place (eg c:\Delphi\Data modeler) and the problem exists.
What more can I send to you? Do you want to access my computer through anydesk to check it if this can help?

I decided to create a new windows account in the computer that I am using and has the exception problem with Data modeler. Installation was not needed, but entering again the licence was requested.

In order to enter the licence info (that will be saved in registry HKEY_CURRENT_USER section) needs administrator privileges and if you enter the original administrator account's credentials, Modeler shows that you are already registered. Not a well designed software as I can see.

I gave administrative privileges to the new account, the licencer run without requesting credentials and Data Modeler works without exceptions.

So, after that....
a) services and machine's background processes does NOT cause the problem to Data Modeler
b) is a "protective" registry key in HKEY_CURRENT_USER causing the problem?
c) Could an other software running only from my original windows account is causing the problem? To be honest I tried to disable anything in startup without success

To be honest, Data modeler already costed me more time to try to find what happens, than the time I expected to gain from its use.

If the above helps you in any to provide a solution, or you need something more, please tell me.

Hi Dimitris, I'm sorry for all this trouble. It's something really new for us, and Data Modeler has been reliably working for many many years already. Of course it's not perfect, but then again, this is new to us and we are learning to know what is going on.

The fact that that Data Modeler shows you are already registered is because you used your original admin credentials, so you are impersonating the "old" user which is already registered.

After you've done all this process I understand that Data Modeler is working in the new account, in the same computer it was not working before right?

Sorry to ask this, but after that, have you tried to use Data Modeler in your original account? Do both accounts have admin privileges?

Correct. But requesting admin privileges from licencer to just write a key in HKEY_CURRENT_USER, it is just BAD design.


I tried but it only works in the new account.

yes, I gave administration privileges also to the new account in order to run licencer

And to finish with all the myths about antivirus and programs that run in the shadows, I did the following:

  1. I exported the registry key HKEY_CURRENT_USER from the account that Data modeler give exception.
  2. I logged out from the problematic account and I logged in the new account that modeler runs without problems.
  3. I checked again that modeler runs without problems and then I imported the HKEY_CURRENT_USER key export from the other account
  4. Now the modeler give exception also from the new working account.

So, lets forget all about programs that Modeler dislikes, and lets talk about what modeler does with registry key HKEY_CURRENT_USER. For sure as we can think, it does not deal only with Software\TMSSoftware.

I think you should now know very well where to search for debugging

Can you please try to

  1. Uninstall TMS Data Modeler
  2. Delete the following registry keys:

Computer\HKEY_CURRENT_USER\Software\tmssoftware\TMS Data Modeler
Computer\HKEY_CURRENT_USER\Software\TMS Software\Data Modeler

  1. Reinstall TMS Data Modeler
  2. Add the license info to license the software again.

And please let me know if this solves the problem in the original account.

And for sure, not only in Data modeler code, but also in its componets, it uses

This was done first, 3 days ago. It did not help.
Repeated again now, exception still exists

Remember In registry there is also information about software that should be run when user logs in. You can check those in Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

DELETED all. Log off. then Log on again. Exception still here.

Yes, but can you please remove those one by one to make it match the old user and see if it affects somehow?

I deleted them all from the New account. I reboot the computer. Exception is here.
I do say again, that it happens when an new or existing project is going to be opened. As it shown, in the video I sent to you.
Please check the components you are using in a project and if they deal with registry.

Please download this custom made dm.exe file from here:

There is a dm.exe file inside it. Backup the existing one you have in your disk, then put this in place and run it. This modified dm.exe should raise the chance of EurekaLog showing debug and call stack information of the error. If you get that, please provide the information to us here so hopefully it might give us a better idea about what's going on, thank you.

I rename original dm.exe. I put the new one in the folder and run it. Same error, nothing new was shown. I can not see a new debug file from EurekaLog in the folder, I hope it sent to you more information.

You see an EGUIException and no EurekaLog dialog?

Exactly. The same image I sent to you from the very first moment

I've sent you a new executable in a private message. Please let me know how it goes with that one, thank you.

With the last provided file, I do NOT get an exception and it works OK