command-line for the "DCC" task is too long

I just went through the process of resolving "command-line for the "DCC"
task is too long" issues with my RadStudio Berlin setup (thanks for
help on this, Bruno).

The basic issue is that I have the
ALL-ACCESS subscription - and I have a LOT of libs installed (so, yeah,
the problem is that TMS has too many cool libs!).

My library path entry is very, very busy.

For each TMS lib, I have an entry similar to :

C:\Users\edward\Documents\tmssoftware<lib name>

To solve this, I added a virtual drive letter to my development computer.

tried using "subst" and "net use", but these failed to be visible to
the subscription manager folder dialog (and also to the Delphi library
path folder dialog).

I tried as both regular and admin user when
running subst and NET USE - neither worked for both the subscription
manager and the Delphi library path dialog.

I ended up adding a registry entry as per :
(scroll down to Map a Folder to a Drive Letter Directly in the Registry)

my case, a new entry  T: with a value of
\??\C:\Users\edward\Documents\tmssoftware  gave me a new drive letter
pointing to the "root" of my TMSSoftware installs.

It was then a
matter of using the subscription manager to uninstall everything (I
might not have had to do that - I'm superstitious about this sort of

I then went into Delphi, and deleted all the lib paths beginning with C:\Users\edward\Documents\tmssoftware (in 32 and 64 bit).

And finally, I reinstalled everything - overriding the default install path to use T: instead.

The installations run flawlessly now.

Hope this helps someone else!


Thanks for sharing this info.

Just a quick follow-up - Windows just performed a major upgrade on me (now build 17134.254) - and in the process wiped out that manually entered "DOS Devices" reg entry.

It also no longer accepted the double "\\" prefix - I had to specify it as

And of course, you have to reboot before this is visible...


We haven't experienced this  here, but glad to hear you were able to fix this.

Just an FYI in case this happens to anyone else...

I just "experienced" Yet Another Windows Upgrade... (Win10 1909) - which also killed the DOS Devices registry entry I created.

When I re-entered it, I accidentally included an extra space at the end of the path:

"??\C:\Users\edward\Documents\tmssoftware "

instead of

Of course, 'T:' couldn't be accessed until I deleted that extra space in the reg entry...