Chart Markers appearing/disappearing but zooming

I have a TAdvGDIPChartview with 1 pane and 6 series.

same chart as described here:
The issue in the post above was resolve.
The new issue I am having is that markers will appear and disappear when zooming in and out at a certain point. I can pin point the exact moment when markers one by one start appearing or disappearing in successive order.
I have tried altering the marker size but issue persists.
I have tried togglling several different properties in the chart panes but issue persists.
any help would be apperciated
Thank you
Mark Knight


Could you send us a simulation of the issue in a sample project? It is unclear how we can reproduce this here.
How many points are displayed, is the range scrolled?
Kind Regards, 
Scheldeman Pieter

at the address above is a demo project of what I am describing. scroll over to the points at around age 50-53. then zoom in and our on the x-axis. you will see that the markers appear and disappear as you scroll in and out.
There is also a video within the zip file showing how this is done using the test app.
thank you for your patience as it's taken a while to get to this demo.

Hi, thank you for your sample, 

Unfortunately we haven't been able to reproduce this here.
Are you using the latest version of the chart?
The latest version should be APR, 2012.

If you are using the latest version and the problem persists please try using
  Chart.Panes[0].Series.Items[0].UseFullRange := True;

for all series.

Kind Regards, 
Scheldeman Pieter

setting the UseFullRange property did not solve the issue of the markers not showing up. I still had to zoom in on the Y axis and zoom out on the X axis to get them show up. similar to the video included in the zip file I posted for you.

If you have the lines from the other series in the pane visible when you zoom in and out on the X axis you'll notice that the markers start to disappear and reappear in coordination with when the other series lines start going beyond the Y axis.

upgrading to the resolved this issue. Thank you for your help.