Can`t open File


FlexCel 6.5 can`t open Excel File.

When opening through ApiMate I get an error "Invalid XML file", but this file opening through MS Excel.

How I can fix this error?

On what e-mail can be sent to a file?


Please send me the file to

Ok, I sent e-mail


Thanks for the file. This file contains a cdata in the footer section, it looks like someone opened an existing file and dropped a cdata there. While I imagine a cdata inside a tag is valid, Excel itself never writes it (), and the xml reader in FlexCel wasn't considering this case.

We've fixed it here so now this file opens fine and the contents in the CDATA are read correctly. We will be releasing 6.6 next week, it will have this issue fixed.

()As you can verify if you open your file in Excel and save it, then FlexCel will be able to open it)

Hello, thank you very much! Let's wait for the release!

Hello, could you tell when it will be published in a new version with the corrections?


Sorry for the delays. I expected to have everything for this friday, but there were a couple of unexpected bugs. One has been fixed and we are looking at the other right now. If everything goes well (which I really hope it does) we'll be publishing 6.6 tomorrow. If we can't make it for tomorrow I'll make an special 6.5.9 release for you with reports disabled.

Ok, thanks;-)

All will be right:-)

How can I get the version 6.5.9?


Sorry again, the bugs proved much harder than what I imagined. But both are solved, we are doing the final build right now, and in some hours 6.6 will be published in the web site.


this is great news. Am very curious on the reporting engine.

Thanks, I am really looking forward to the release too. This version has a very special meaning for me, because FlexCel has always been, from the first internal version in 1996, a reporting component. All the other engines (xls/X engine, recalc engine, pdf engine, etc) came later, and the focus was always to allow reporting. So it made no sense that FlexCel 6 didn't had a native one, even if you coud use the v3 FlexCelReport with XlsxAdapter.

And 6.6 marks also an inflection point for FlexCel, because now 100% of the functionality in FlexCel .NET has been migrated to FlexCel for VCL.From now on, both components will be developed in parallel and releases will be simultaneous. 

I'll be blogging a little about all of this later this weekend.

so this means that most of the documentation for reports can be used one to one with the vcl version? E.g. Defining bands, placeholders etc. in the template file will be the same?

Yep, templates are exactly the same. I am including more than 30 new demos for reporting, and all the teplates came from the demos in FlexCel.NET, without modifications (more than a little modernizing of the config sheet, in preparation for the new report designer that isn't ready yet but will be soon).

The data layers are of course a little different because a .net datset or linq expression isn't the same as a vcl dataset. But they are as similar as can be.

6.6 is already up in the registered page.


It`s goog new!!!!!

Thank you very much !!!! Congratulations on your new release!!!!!


After install version getting the error:

Can't open file: C:\Comps\TMSSoftware FlexCelVCL\Setup\bplfolderWin32.txt
EOSError: System Error.  Code: 2.
?? ??????? ????? ????????? ????
Can't open file: C:\Comps\TMSSoftware FlexCelVCL\Setup\bplfolderWin64.txt
EOSError: System Error.  Code: 2.


We're also getting Can't open file error on installation of 6.6 and i have no backup of 6.5 so we need a correction asap please,



This seems to be an issue with the new setup, which creates symbolic links to the bpls. I can't reproduce it here, and some customers seem to have the issue and some not, so I will need a little more info to find out what's going on.

First of all, as an urgent workaround you will be most likely able to install if you deselect "Create symbolic links for packages..." (last option in the "Select additional task" pages in the setup). But you will have to add the bpl folder of FlexCel to the windows path.

But I think we have figured out why this is happening, we'll have a new setup in some hours when the build process finishes.

Now, to fix this,

Yes, i`m use "Create symbolic links for packages"

System Info: OS - Windows 7 x64
Delphi: Embarcadero® RAD Studio XE2

When will I receive the corrected version?