C++ Builder Pro 11

Howdy All!

I have reported this on Friday and I was having a back-n-forth with Bruno.

The issue is that the Cryptography Pack Installer doesn't build the Android 32 or IOS 64 libraries / hpp/ obj files for C++ Builder Pro only (no Delphi personality). The FNC Core/UI Pack installs fine.

I tried using the MSBuild command line per Bruno's suggestion. I used the following lines:

Android 32:
MSBuild TMSCryptoPkgDXE14.dproj /target:Build /p:config=Release /p:platform=Android /p:DCC_DcuOutput="C:\Program Files (x86)\Embarcadero\Studio\22.0\NewVCL\TMS\CryptographyPack\Builder11\Android\Release" /p:DCC_HppOutput="C:\Program Files (x86)\Embarcadero\Studio\22.0\NewVCL\TMS\CryptographyPack\Builder11\Android\Release" /p:DCC_ObjOutput="C:\Program Files (x86)\Embarcadero\Studio\22.0\NewVCL\TMS\CryptographyPack\Builder11\Android\Release" /p:DCC_BpiOutput="C:\Users\Public\Documents\Embarcadero\Studio\22.0\Dcp" /p:DCC_DcpOutput="C:\Users\Public\Documents\Embarcadero\Studio\22.0\Dcp" /p:DCC_BplOutput="C:\Users\Public\Documents\Embarcadero\Studio\22.0\Bpl"

The header/object files for Android are created. When I try to compile / link my application for Android32, I get the following linker error:

dandroid Error] C:\Users\Public\Documents\Embarcadero\Studio\22.0\CatalogRepository\AndroidNDK-21-22.0.42600.6491\android-ndk-r21\toolchains\arm-linux-androideabi-4.9\prebuilt\windows-x86_64\bin\arm-linux-androideabi-ld.exe: error: cannot find -lTMSCryptoPkgDXE14

Obviously, I missed something or something got messed up.

Any chance of getting an installer that works ASAP? I really am running against a deadline for a proposal.

Thanks in Advance,


OK... I did an absolutely clean install of Windows and C++ Builder Pro 11.

The install for C++ Builder 11 still needs to be fixed to build the Android/IOS versions of the libraries if the platforms are available. The same install program works in Rad Studio 10.4.2 (I tried it on an older computer to verify).

Any how, I used the MSBUILD to get the Android version build. I will see if I am moving in a straight line tomorrow.



We have investigated this deeper and finally found the Delphi 11 related culprit. We applied a fix in our installer and a new version is now available.