Button images

IW 12.1.22
This is driving me nuts!
I have a TIWImageButton component on a form.  I have assigned an image to it via the ImageFile-FileName property.  At design time the button shows the image as I would expect.
When I run my app in Firefox (12.0), in place of my image i see "Submit Query"
When I run app in IE (8) I see a red "X" in place of my image
What am I doing wrong?

Incidently when I run the demos, none of the buttons using Custom Images display correctly on either browser.  They all show the "broken image" image.  They are ok with the default images.  For example in the AsyncNav demo, the custom toolbar buttons do not display, despite me having a \files directory with the correct .png images avai

Any help would be appreciated
Simon (newbie)

Can you please make sure the url to the image files in the rendered HTML is pointing to the exact location of the image files?

Please note that in IW 12.1.x, the default files folder is called "wwwroot". Do you have a "wwwroot" folder in your project's output directory?

Many thanks - sanity restored.