Bug ? TAdvMultiColumnDropDown


This component behaves very strange:

1. No matter what selection color I choose.. lower hal is always yellow

2. Everytime I click the button to show the columns it looks different. This without anycode applied.

Picture 1: When I click the first time
Picture 2: After second click... looks always different.

Comments / Help appreciated

Is this the latest version ?
Did you try the demo ? With our demo or test apps, we can't reproduce this behavior here.
Please provide more details.

Hello Bruno

Yes, it is the latest version of TAdvMultiColumnDropDown and the TMS Component Pack.
I can't find a demo of this component to test it here. All I did is set Header to visible := False; and changed some colors.

Can't be reproduced,

see test project

Tested the demo-project and have the same result.

First click on "arrow" shows the correct display.

Then I click the arrow again without choosing an item. Next time I open the dropdown again I get:

No code changed. Just Opened and run. Noticed also, that first entry/records gets duplicated.


We could reproduce & fix this issue. Next update of TAdvMultiColumnDropDown will address this problem.

Thanks.... I guess.

The main bug was solved with the latest release. Still a bug left: Selection color does not get applyed as set in properties. Top part of selection with correct color, but lower half always yellow.

Just try to change selection color to reproduce this effect.


The selection is a gradient. It is normal that when you leave SelectionColorTo to yellow, the bottom part will be yellow. If you do not want a gradient, set SelectionColorTo = clNone

Try again and change the Gradient-to-color to another color than yellow and check the result. It will remain yellow.

Right click on the component and set the Style to a different style than Office 2007, Windows Vista or Windows 7

Okay - please explain this...

Did you change the style as I requested?

Yes, I did. And it work. Neverthelesse: If I can change SlelctionColor manually, why don't I see the result ? Or do you want to tell me that I'm bound to the preset from "style" ?!

Using latest version of TAdvMultiColumnDropDown and got similar issues with colors after first click but now a bit different. Just drop down the component into a form, make couple of columns and add few items to have something to be drop down and then:

- click it for first time to drop it down, all color are fine;
- instead of clicking on any item from the drop down list now click somewhere outside of it, it will close drop down;
- now click again on arrow or itself to drop down it and you'll see all colors are screwed, exactly as described by OP in first post and there is no way to get it back
If you first time click on any item from the drop down list it will work fine even if later you click outside of it.
I don't want to be rude but honestly I'm a bit confused about the way you guys are testing your code at  TMS and the patches you're releasing, perhaps you should implement a better test case model to follow before releasing products to public/customers?
I also have the application crashing under some circumastances after I added some TMS controls (this happened years ago while working for other project which included an older pack of TMS controls) and I'll report it when I have a trace of the problem.
Should I expect a fix to be included in next release?
Cornel I.

I cannot reproduce this.
Test project: http://www.tmssoftware.net/public/Project3_8.zip 

Are you sure you effectively have v1.1.1.4 linked at runtime?

Hello Bruno,

Thanks for your quick reply, I bought TMS pack about two weeks ago on on 5/10/2010 and version reported by TAdvMultiColumnDropDown is Last night I downloaded latest pack found under my account and get same result using your test project. Just click on the form when you first time have the dropdown and you'll notice than more than just the colors beign screwed (the first row becomes yellow for example) but the rows as well are not correct, first row gets duplicated. I'll create a screenshot and post it. I also added some code to display version and it says as shown in Object Inspector at design time. I can send you my compiled sample project if this helps.
Cornel Iordache

Added screenshot

Uploaded with ImageShack.us

Been a while, could you please update on this issue?


As I am unable to reproduce this problem, 
I am not able to investigate this deeper. I would really need some sample source app and/or exact & detailed steps to be able to reproduce this.