10.4 Demos


When I run any of the demos on my iPhone 11 they no longer take up the whole screen. Is there some change in 10.4 to control this. Applies to any sample (not just FNC) and also any new app. I am on iOS 13.5 and XCode 11.5.

Am asking here as a general search of the web reveals nothing to me!



Embarcadero forums would be the best place to ask this or to report such issue.

I have but don't often get replied there. Can you at least tell me if you can replicate it?

We'll have a look when we can allocate time

Do you have this issue with a new project? If so, then unfortunately this is a bug in RAD Studio 10.4 related to iOS 11. If not, then compare the project files and see if there are additional settings that are changed between older RAD Studio versions and 10.4. The demos were created in an older environment. Removing the dproj, opening the dpr afterwards can also potentially fix the issue.

Yes. Same problem with a new project. It just seems crazy that something as fundamental is thiswasn't picked up in testing.

Most likely related to


I think you're probably right. I haven't been able to figure out how to use the storyboard yet.I can only see new 2x and 3x images which are presumably related but just leaving these as the Embarcadero defaults still results in the same problem.

I just tried it on my notebook and it works fine on that, which only has Sydnet installed, so it must be related to having both Rio and Sydney installed on the same PC.

Maybe it has something related to the template used for new projects, perhaps you can compare both project files. Also compare the info.plist and the settings in the IDE.

Interesting. Using the Embarcadero sample project called ScrollableForm. I have compared all files and the difference is in the info.plist.TemplateiOS.xml file :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<%StoryboardInfoPListKey%>  <--- This line is missing on my main PC

Making them the same resolves the issue.


Now I have to work out why!