XE2:tmsexdex2.bpl missing from your computer...

I've just installed RAD Studio XE2 and am attempting to install all of the TMS compoents that we purchased.

Is there a specific order that they need to be installed?
I'm getting errors:
The program can't start because tmsexdex2.bpl is missing from your computer. Try reinstalling the program to fix this problem.
- This file C:\Users\Randy\Documents\tmssoftware\TMS Component Pack\DelphiXE2\TMSExDEX2.bpl exists.
Can't load package C:\Users\Randy\Documents\tmssoftware\TMS Component Pack\DelphiXE2\TMSWizDXE2.bpl. The specified module cannot be found.
- This file C:\Users\Randy\Documents\tmssoftware\TMS Component Pack\DelphiXE2\TMSWizDXE2.bpl exists.
My Library path:
C:\Program Files (x86)\ComponentAce\ZipForge\Lib\Delphi XE2 and C++ Builder XE2;$(BDSLIB)\$(Platform)\release;
C:\Program Files (x86)\FastReports\LibD16;
C:\Program Files (x86)\Raize\CS5\Lib\RS-XE2\Win32;
C:\Program Files (x86)\Raize\RC6\Lib\RS-XE2\Win32;
C:\Users\Randy\AppData\Roaming\IntraWeb XII\Libxe2W32;
C:\Users\Randy\Documents\tmssoftware\TMS Async32\;
C:\Users\Randy\Documents\tmssoftware\TMS Async32\DelphiXE2;
C:\Users\Randy\Documents\tmssoftware\TMS Component Pack\;
C:\Users\Randy\Documents\tmssoftware\TMS Component Pack\DelphiXE2;
C:\Users\Randy\Documents\tmssoftware\TMS Component Pack\xlsAdapter;
C:\Users\Public\Documents\RAD Studio\9.0;
C:\Users\Public\Documents\RAD Studio\9.0\Bpl;
C:\Users\Randy\Documents\tmssoftware\TMS Instrumentation Workshop\;
C:\Users\Randy\Documents\tmssoftware\TMS Instrumentation Workshop\DelphiXE2
I used the automated installers for the TMS Component

Please add the folder where the package .BPL files are located to your system path. See Control Panel, System, Advanced Settings, Environment for editing the system path.

This is also explained at http://www.tmssoftware.com/site/install.asp, see error 5.

TY for the quick reply.  I added both:

C:\Users\Scottg\Documents\tmssoftware\TMS Component Pack\DelphiXE2
C:\Users\Scottg\Documents\tmssoftware\TMS Component Pack\bpl
The file (TMSExDEX2.bpl) resided in both of these folders.
to the system path and continue to have the same error.  Keep in mind that I can Clean/Build the IW12TMSDXE2.DPROJ without error, it's when I select "Install" that I get the error.

I've even copied TMSExdex2.bpl to the C:\Users\Randy\Documents\tmssoftware\TMS Component Pack\ folder.

Same result.
BTW: "Scottg" in the previous post should have been "Randy", I mis-typed the path in the post, using another user's name.

TMSEXDEX2.BPL is in your system path, I can absolutely not see a reason why Delphi XE2 wouldn't find it on startup.

As a quick workaround, try to copy TMSEXDEX2.BPL in \Windows\System32

Hmm... copied it to the \Windows\System32 folder. Same error.

Copied it to:
C:\Users\Public\Documents\RAD Studio\9.0\Bpl
and it worked.

Very weird.  It's Windows 7 Pro, I... I DO have admin rights, but you never know with Windows 7.

Anyway, thanks for pushing me in the right direction.
I'm now attempting to install TMSASPGridDXE2 and get the following error:
[BRCC32 Error] TMSASPGRIDDXE2.vrc(60): file not found: C:\DelphiXE2\AdvSpreadGrid\TMSASPGRIDD2011_Icon.ico
TMSASPGridDXE2.vrc loads and the code line reads:
MAINICON ICON "C:\\DelphiXE2\\AdvSpreadGrid\\TMSASPGRIDD2011_Icon.ico"
This looks like a hard coded path to a non-existent folder.  Also, I cannot find TMSASPGRIDD2011_Icon.ico anywhere.

Now, when I open a project that was created using Delphi 2010 (and worked fine under that environment), I get the following error:

[DCC Fatal Error] BaseForm.pas(7): F1026 File not found: 'IWTMSImgCtrls.dcu'
Does this unit exist in XE2?
I also get the "red underline" in the uses clause for IWTMSCtrls and IWTMSMenus.