WordWrap not working in TMSFNCButton


I can't get the WordWrapping feature to work when using an FNCButton in a WEB Core application. The same FNCButton wraps correctly if I'm creating a VCL application.

The strange thing is that it wraps the text in the IDE at design time, but does not wrap at runtime inside the browser. I've tested with three different browsers and the results are always the same.

Hello Steve,

Could you tell us which version of TMS WEB Core and TMS FNC UI Pack that you are using?
I've just tried to simulate your problem locally, but was not able to reproduce this.
I just placed a TTMSFNCButton on the form, set wordwrapping to true and set the text to 'Some text for word wrapping'. This works as expected for the browsers that I've tested (Google Chrome and Firefox).

Hi Gjalt,

I was using WEB Core 1.5.4 and FNC UI Pack

But after I read your reply where you said that you couldn't reproduce the problem, I went to check for updates and I downloaded the latest FNC UI Pack

With the newest version, the result is the same. The text wraps properly in the IDE, but not at runtime.

So I decided to try a second test using a virtual machine. I downloaded the latest TMS WEB Core and the latest FNC UI Pack. With the virtual machine, the problem is even weirder. I can compile the project successfully and launch it, but when the browser opens, I see nothing but a blank page. No matter what kind of components I place on the form, the browser always shows a blank page. This happens in Firefox, Chrome, and Edge.

A workaround for your blank page problem is to save the project, this should solve that issue.
We are currently investigating the cause of this.

For the TTMSFNCButton, would it be possible to submit the dfm code of the button (and the component on which it is placed, if this is not the form)?

Yes, the blank page problem is fixed by first saving the project. Thank you for that tip, because in a few more minutes I was about to start uninstalling things to try and figure out what's happening.

For the wordwrapping issue, when you said "and the component on which it is placed", I immediately got suspicious, so I tried a new test. In my original project, all of the buttons are inside various groupboxes. And those don't want to wordwrap, no matter what. But when I tried placing an exact copy of the same button outside of the groupbox (on the main form), it works properly.

Please see attached sample project.

WordWrap Test.zip (6.0 KB)