WebGMaps V2.7.0.0

Just installed V2.7.0.0 and when I run the program I get:

Error: Property Routing.PolygonOption.Icons does not exist.

Any clues

What program do you run?
There is no property Routing.PolygonOption, the property that exists is Routing.PolyLineOptions and that property is available in the v2.7
Please scan your full hard disk for old versions of FMX.TMSWebGMaps.pas and make sure only one and the latest version is installed. With a clean setup of only the latest version, there shouldn't be any issues.

Sorry again, you are correct. The error is:

"Property Routing.PolylineOptions.Icon does not exist"

I deleted everything to do with FMX.TMSWebGMaps, including the Delphi BPL and DCP directories.

Reinstalled the FMX Web GMaps V2.7.0.0 and it is exactly the same.

It happens if I target an Android or a Windows platform.

The TMS WebGmapsDemo program is also gives the same error.

Is this a clue to anything:

At design time I click on the GMap component.

In the Object Inspector I select Polylines

Click on the 3 dots and "Add New"

Now delete what you have just added.

Pointer error + Access Violation + Catastrophic Failure


I can't see any of these issues here with v2.7.
Can you verify by inspecting FMX.TMSWebGMaps.pas under const that you have effectively the source version?

Correct it is V2.7.0.0 is the pas file. Also When Delphi starts up, the splash screen shows V2.7.0.0 as well.

Then you should see in this .pas file the type Routing.PolyLineOptions and thus, when you compile your app against this file, it should find this type.

The problem has been solved.

It would appear that I have GMaps V2.5.0.2 installed as well.

It looks like TMS changed the folder from:

TMS WebGMaps for FireMonkey



The new installation did not delete the old folder and also left the Delphi Library settings containing both the old and the new folders.


Thanks for letting know all is fine now.
The normal procedure is to run the uninstaller (from Windows Control Panel) and then install the new version.

OK. I always thought, that as the installer gave you the option to remove previous versions, this was not necessary.
But maybe not the case if the installation directory has changed.