Webcore not working after installation of Apache

Webcore was working before. I have had to install xampp in my pc as I am also working with php/mysql.

I also update to the latest webcore 1.9.7

I have stopped the apache server. But I still can not debug (or run) the webcore application from the IDE.

TMS Webserver is running in

2022-02-16 12:44:37.120 [INFO] Server added: http://localhost:8000/PBL_Web
2022-02-16 12:44:37.199 [INFO] Server running: http://localhost:8000/PBL_Web

The browser tells me The site can't be reached

The log file :-

16/02/2022 13:08:52 - TTMSWebIDENotifier.ProjectGroupCompileStarted
16/02/2022 13:08:52 - TTMSWebIDENotifier.BeforeCompile
16/02/2022 13:08:52 - TTMSWebIDENotifier.FileNotification [C:\Users\Rohit\AppData\Roaming\Embarcadero\BDS\22.0\UserTools.proj]
16/02/2022 13:08:52 - TTMSWebIDENotifier.ProjectCompileStarted
16/02/2022 13:08:52 - TTMSWebIDENotifier.ProjectCompileFinished
16/02/2022 13:08:52 - TTMSWebIDENotifier.AfterCompile
16/02/2022 13:08:52 - TTMSWebIDENotifier.AfterCompile [0, I:\DELPHI\WEB\PBL_WEBSITE\Win32\Debug\PBL_Web.exe, I:\DELPHI\WEB\PBL_WEBSITE\PBL_Web.dpr]
16/02/2022 13:08:52 - TTMSWebIDEAfterCompile.InternalExecute [I:\DELPHI\WEB\PBL_WEBSITE, I:\DELPHI\WEB\PBL_WEBSITE\TMSWeb\Debug, C:\Users\Rohit\AppData\Local\Temp\, 0]
16/02/2022 13:08:53 - TTMSWebCustomPas2JS.Init [f:\tmsx\TMS WEB Core RSXE12\Bin\Win32\libpas2js.dll]
16/02/2022 13:08:57 - TTMSWebIDENotifier.ProjectGroupCompileFinished
16/02/2022 13:08:57 - TTMSWebIDENotifierDebugger.LaunchWebServer
16/02/2022 13:08:57 - TTMSWebIDENotifierDebugger.LaunchWebServer, [f:\tmsx\TMS WEB Core RSXE12\Bin\Win32\TMSWebServerManager.exe, -s http://localhost:8000/PBL_Web I:\DELPHI\WEB\PBL_WEBSITE\TMSWeb\Debug]
16/02/2022 13:09:33 - TTMSWebIDENotifierDebugger.LaunchWebServer
16/02/2022 13:09:33 - TTMSWebIDENotifierDebugger.LaunchWebServer, [f:\tmsx\TMS WEB Core RSXE12\Bin\Win32\TMSWebServerManager.exe, -s http://localhost:8000/PBL_Web I:\DELPHI\WEB\PBL_WEBSITE\TMSWeb\Debug]

One things strange is that its using RSXE12 instead of RSXE14. I am running Delphi 11

Is the port 8000 occupied by another process or program? Can you quit the web server and re-run the project?

That didnt do anything. I ran tcpview and netstat. The process System is using port 8000. On googling, it seems thats how it works as windows api are being used.

I reinstalled webcore and only registered the X14 webserver - no luck.
I have tried restarting the webserver a few times - no go.

If the webserver cant listen on port 8000, why doesnt it complain in the window and in the logs ?

Conversely, is there anyway to use the apache server instead ?

I have no experience with Apache or what it does when installing and what it interferes with.
Try running the tool TMSHttpConfig.exe from the Bin\Win32 folder and verify that http://+:8000/ is registered

Its in the list, so I assume it is registered.

I'm not sure what interferes on your machine.
Did you try another port number for our debug webserver?

PHP is using 9000. I can see that the TMS server is using 8000. There are no setup options on the server GUI. How do I change the port ?

Start URL (and thus port) is set under options:

Use the TMSHttpConfig.exe tool from the Bin\Win32 folder to reserve this URL.

Port 8000 was already reserved.
I did the following

  1. Changed the port to 8800 in the options
  2. Ran the HttpConfig but I didnt think that $() would work so I only reserved http://localhost:8800
  3. Rebooted the server
  4. Disabled xampp
  5. Using Debug Config that used to work
  6. It uses the port 8800

I get

The site can't be reached.

The url in the browser is


So what url should I reserve, just the folder, including the html, or with the arguments ?

Did you reserve

I did now, but it still doesnt work. I restarted the TMS server after changing it. I also tried a few other ports. And xampp was not running at this time, ie apache, and mysql servers were off..

When you open the debug server window, you see no accesses then, like in this example?