V3.5.0.0 TTMSFMXBitmap

The TTMSFMXBitmap component has disappeared from the installed components!

Please use the TTMSFMXImage component, which is indentical to the TTMSFMXBitmap component.



I have the same issue! But I cannot find any TTMSFMXBitmap component on my form. Form is also not opening because of this issue.
How can I fix it??

As already mentioned in the second post, you'll need to use TTMSFMXImage. You can replace TTMSFMXBitmap with this component, it should behave identically. There was an issue with duplicate class types that we needed to fix in order to avoid ambiguous errors while compiling some combination of components.
Pieter Scheldeman2016-12-20 14:49:34

I cannot find ANY TTMSFMXBitmap on my form. But I get this error.
So how to fix it if I cannot replace it? :)


If you use a TStyleBook for the TTMSFMXGrid, you'll need to remove the TStyleBook and re-add it by right-clicking the component and clicking "Edit Custom Style"

How should I remove the stylebook if the form is not opening because of this error.
The style is embedded to the form!
So how should I do it? Styles are stored binary.


Unfortunately you'll need to open the .fmx file in a text editor and remove the StyleBook object.

Ok - this I can do.
But how to put the style back into the form?
I have just the raw data what I have removed/copied one step before!?

You could try to paste this in a new form, but the error will be similar, there is unfortunately no way to extract faulty resources from a binary TStyleBook. This could be done in older versions of RAD Studio where the TStyleBook resource was plain text. You'll need to remove the TStyleBook from the form and re-add a new TStyleBook. If there is a possibility that you can open the form in a new project you could then Save the TStyleBook content to a .Style file and manually remove the TTMSFMXGrid entry.

How to get back the previous version of TMS Pack for FireMonkey??


Can you send us your project / form file, we'll look into this here.

I can send you the style files - to which email address?

You can send them to support@tmssoftware.com

email sent - thanks!

Just an idea... Create a new descendant of TTMSFMXImage and name it TTMSFMXBitmap and install it in an own package. Then you should be able to open it and remove the entry.

I suspect he problem is also with images kept in an image container as removing the style sheet did not allow me to open the form. I have hundreds of images stored this way in many forms so no way I am going to redo them all. Thank heavens for backups - I was able to go back to a previous TMS version and rebuild the project.

Unfortunately this will rule out any further updates to the TMS package and may have similar implications to Delphi if the old version doesn't load easily into new releases. Seems OK with Berlin update 2.

If you have non-binary style sheets you can simply replace TTMSFMXBitmap with TTMSFMXImage.

I tried my solution and it worked quite well... Just create the new component based on the TTMSFMXImage and let Delphi create and install it it in an own package.