"Uses" unit compiler error

Server 2012 R2 Delphi 10.1 Berlin.

I uninstalled the previous version of TMSpack using the unins000,exe and installed pack version without any apparent problems.

But when I try and compile a project that had no problems before the upgrade I am getting an error in a couple of units listed in the Uses clause of AdvTouchKeyboard.pas

The units are Windows and Messages but there are no compiler complaints about the other 12 units that are listed.

The Delphi library paths all seem to be correct and absolutely nothing had changed in the project since it was last compiled.

Do you have any ideas of what I need to do to correct the problem other than editing the pas and inserting the long path names for these units?

Thanks in advance...

Please have a look at the project unit scope names. These are normally by default set to:

and with these default settings, it should compile without issues.

I will give that a try Bruno.

Thinking it might be a namespace issue since the other user units were not throwing the same error, I added the paths $(BDS)\lib\win32\debug and $(BDS)\lib\win32\release to the library but that didn't help.

You are a wizard Bruno.

Your suggested solution solved the problem.

Thanks a million - Kevin