Updated components, now when I open my project it crashes the IDE

Updated my FNC, VCL UI Pack, TMS Async and Logger components, now when I open my project it crashes the IDE with an Access violation error. Before the update everything was fine. What do I do? How can I install older versions of the components so I can work on my project? I can open some projects that, I believe don't use the FNC components.

Have you completely uninstalled older versions? Did you install the latest versions of all components? What does the access violation tell? can you provide more info?

I am using TMS Subscription Manager 2 (All Access). It did uninstall all updated components first. And it installed the latest version.

At first I saw no error message on the screen. But then I found that if I open a "safe" project first; then "Close All", then open my project group (the one that crashes) I could see the error. The error would change. I have several projects in a project group. It would complain about one of the projects saying that it is "Unable to create project XXX" (see first image), then remove that project from the project group. I let it do that until there was only 1 project left in the group. The I received the error in Screen shot 2, saying "Error creating form: Access violation at address 2D5284D4. Read of address 2D5284D4". There projects use components from the TMS VCL UI and FNC.

I believe the form trying to open in the main form. But, I can open the main form individually (without the project).

Screen Shot 1:
Screen Shot 2021-07-22 at 2.55.16 PM

Last Message screen shot 2
Screen Shot 2021-07-22 at 3.46.10 PM

I am able to open my project now. I'm not sure why. Here is what I did.

  1. Removed FNC UI components; Tried to open my project. = crash; Re-installed FNC.
  2. Removed VCL UI components; Tried to open my project = crash; Re-installed VCL UI.
  3. Removed TMS Logging; Tried to open my project = DID NOT CRASH; Re-install TMS Logging and it still opens fine.

I have no explanation for this. But, I am glad I can get my work done.

Side note: I currently do not use TMS Logging in any of these projects, but I do use FNC and VCL UI components in the main project of this group.

I am using:

  1. a virtual machine (Parallels) Windows 10 Version 20H2; OS Build 19042.1110; 64 bit; 16 GB RAM.
  2. Dephi 10.4 Update 2

Thank you for this additional info, Virtual Machine, Remote Desktop or any other remote/virtual software tends to have issues in various areas. Mostly at designtime, but installation issues can also occur.