TWEbGMapsGeocoding and APIKey

I have rececently upgraded from WebGMaps v2.6 to v2.8 and have now had to use an API Key for GeoCoding.   It works and i can see my Geocoding requests in my API Manager Dashboard.  For testing purposes my API key has no restrictions.  The API key covers Geocoding, JavaScript, Directions, Elevation and Geolocation (as suggested in WebGMaps manual)

The problem though is that the exact same application when run at my client does not work.  WebGMapsGeocoding1.LaunchGeocoding returns "erOtherProblem" which the help file says is an unknown problem.

Am i doing something wrong?



It could be an issue with Indy SSL that is used for using the Google API with HTTPS.

Can you verify if these DLLs are on the client's machine: libeay32.dll & ssleay32.dll


I am having the same problems after upgrading. The dll are on my computer but I get Always erOtherProblem as result of WebGMapsGeocoding1.LaunchGeocoding.

I have tested this wit Delphi Berlin and Delphi Tokyo, both the same result.

When going back to version ( The only other one i had ) and the problem is gone.

Any idea what si going wrong ?

P.s. Where can we download older versions of TWebGMaps ?

Can you use a (free) tool like Fiddler to monitor the HTTP requests from the Geocoding component to see what exactly is happening?

My client was missing one of the dlls.  I have now copied both into the application folder and all is now working correctly.

Whilst copying the dlls I found that I had a variety of different versions on my pc and initially I copied ones that did not work.  The ones that did work came from my C:\Program Files (x86)\Intel\iCLS Client folder.

This information might be useful for Gert.  When I first compiled my application I pasted my API key directly into the Geocoding properties via the Object Inspector.  The Geocoding did not work and in desperation i then coded the APIKey as part of the application and then all worked ok.  I have subsequently tried to replicate this problem using the Object Inspector rather than code but it now always works ok.  I do not know if I did something else at the same time but the coding option might be worth checking.



Even on my development PC the geocoding doesn't work in this version.

I don't use an APIKey.

Wat strange is that it used to work in one version earlier. Is there something that is changed ?

Afaik, with the latest Google geocoding API, it is need to use an API key. Can you please request such key and retry with the API key defined?

Oke, I will try i with a API key. Strange becaused It still works without a API-Key in the older version