TWCsmart UI, made for which SmartElements version?

Which version of smart elements is the TWCSmartUI made for or works with?
I tried from V10 to V14.2 (licensed version) of smart elements but on the demo, when switching to form designer, VSC it always complains about missing properties and sometimes crashes (the " we are having issues" dialog).
I have fixed them by opening the dfm and removing the properties that generated the error.
For that reason I have not used it before. I have a use for it now, but I don't want to use it if its potentially failing with other than the intended version, not mentioned on the documentation.

Asked the question to JQwidgets and they say TMS are the developers, they don't know also.


We used to create the wrappers for Smart UI, but stopped testing against each version. Unless the JQWidgets team broke backwards compatibility, newer library versions should still work with the wrappers. With that being said, we'll consider to test and update for a newer version.

Regarding to the DFM issue in VSC, we'll investigate that. However, design-time experience has nothing to do with the library version. If you don't have issues other than the missing properties, then it's safe to assume the wrappers will work. If you have other issues too, then please report them with details so we can investigate.

Am using TMS WebCore v2.0.5946 for VSC and just tested with versions 12.0.0 and 14.2.0 of SmartUI, both result in the same error and crash when switching to design view.
So far the only issue I have seen is that, but it prevents me from attempting to create something more time consuming.
Here a couple of screenshots. The one made earlier (see the clock in the shot) is 12.0.0.

BTW usually properties are missing when porting from Delphi to VSC, but the crash is not usual.

We will check this as soon as we can allocate time.

Thank you..

We've updated the source files. Can you please try to download and install it again and see if it resolves your issues?

Sure, thank you. Downloading right now, will test later.

After downloading the new version, I tested it with the demo included.
Copied smart.elements.js, created styles folder and put there smart.default.css, the fonts folder and added all the above to the project, just like I did before
I used smartUI 14.2.0 licensed version. Used files from the sources folder, not from sources-dev (smart default has 14.2.5 in it's header).

On the editor, it does not crash anymore, and switches to form designer without a problem.
Compiles OK but it has a runtime error, below.
With a breakpoint I found that the error is triggered on line 112, that reads:

WebSmartListBox1.Insert(0, sl[I]);

The httpwebRequest is indeed obtaining the data and the process before that line seem to prepare it. Maybe is just an error on the DEMO app logic, but would be nice to see it working.

This is the error. I think you can easily reproduce it. (reinstalled the previous TWC smart ui package and it still runs fine, although the designer crashes).

Uncaught TypeError: this.GetElementHandle(...).insert is not a function | TypeError: this.GetElementHandle(...).insert is not a function at Object.Insert$1 (http://localhost:8080/SmartUIDemo.js:55501:31) at Object.AddDataToCarousel (http://localhost:8080/SmartUIDemo.js:55742:33) at Object.WebHttpRequest1Response (http://localhost:8080/SmartUIDemo.js:55664:12) at Object.cb [as FOnResponse] (http://localhost:8080/SmartUIDemo.js:245:19) at Object.HandleResponse (http://localhost:8080/SmartUIDemo.js:51279:42) at XMLHttpRequest.cb (http://localhost:8080/SmartUIDemo.js:261:28)
at http://localhost:8080/SmartUIDemo.js [55501:31]

Thank you for reporting back, we'll investigate this further.

Could be a hiccup in file deployment. In our case one of the string variables in the JavaScript file was cut short causing the JavaScript to fail loading which lead to this error. However after cleaning the project this resolved itself so it's unclear what happened exactly or how to reproduce it again.

When you launch the demo project, it opens in a browser. Can you check from the browser's developer tools in the Console tab what other further errors are shown?

I copied the project from the Mac to the Windows 11 pc, and the outcome is the same.
On the console, first error seems to indicate that the smart.elements couldn't find something. This could lead to the problem.
The only thing I can think of is a dependency. On the second screenshot you can see the project contents. I followed the instructions, and as I mentioned, with the previous twc component, using the same file location and smartUI versions, it only fails when switching to form but removing the missing properties on the dfm resolves it.

I can mail you the whole project if you want.

The error message means the smart.elements.js file was not found. If you take a look at the Debug folder, that is indeed the case, it was not deployed.

Did you add it to your project properly? Right click on smart.elements.js > Add to project

You are right. I was so sure I added the file to the project, that I didn't stop to verify it was there.
Well, I added the file to project and it is working perfectly now.