TTMSFNCRating: "Class not found" when inside a TStyleBook

While migrating from FMX to FNC components we replaced a TTMSFMXRating inside an TStyleBook with its FNC counterpart, but at runtime, at form creation, encontered the exception Class TTMSFNCRating not found.

We tried adding a TTMSFNCRating outside the stylebook, in the same form thinking it was a initialization problem but the result was the same. After inspecting the source of this component we noticed that this particular class lacks a RegisterRuntimeClasses procedure which is present on other FNC classes, so we added the override:
procedure RegisterRuntimeClasses; override;
And the implementation:


Which, after recompiling the runtime package, effectively solved the problem, but it would be awesome if this is included in a eventual update for TMS FNC UI Pack.

This has been added and will be supported in the next update of the TMS FNC UI Pack.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.