TTMSFNCPageControl problem loading style

OS: Debian 10 LXDE 64bit
Lazarus 2.0.12
FPC 3.2.0

When I have TTMSFNCPageControl or TTMSFNCListBox or TMSFNCCheckedListBox1 on the form, I have the following problem, when loading the style.


Hi, which style are you loading exactly? can you provide more detailed instructions?

Loading style is not a problem, it works properly for other components.

The problem exists when I put these components:
TTMSFNCPageControl or

An error occurs when compiling from lazarus.

But binary works slower

Please let me know exactly which style or action you take to get an error. Which code are you using exactly? Please send us a sample demonstrating the error

{$mode objfpc}{$H+}


Classes, SysUtils, Forms, Controls, Graphics, Dialogs, LCLTMSFNCStyles,


{ TForm1 }

TForm1 = class(TForm)
TMSFNCStylesManager1: TTMSFNCStylesManager;
procedure FormCreate(Sender: TObject);



Form1: TForm1;


{$R *.lfm}
uses jsonparser;

{ TForm1 }

procedure TForm1.FormCreate(Sender: TObject);


Whether the example is sufficient or needs more

We are able to reproduce this and are currently investigating.


We have investigated this here and noticed this is a bug in TStringStream, which doesn't increment the Position property automatically when using ReadString(); . We have fixed this issue, this issue occurs in FPC 3.2.0 . We already have reported this issue but it's unclear if this fix has made it in newer FPC versions.

Whether the fix is ​​in the next version or the fix is ​​in FPC 3.2.0

The fix is in the next version of TMS FNC Core. It's a workaround for a bug in FPC 3.2.0. I assume the issue should be fixed in FPC 3.2.2 but it's unclear.

Thank you

1 Like

I tried the new version
lazarus 2.0.12
fpc 3.2.0
Run-> Clean Up and build - Clean up and Build

I get the following message

Lazarus 2.1.0
FPC 3.3.1
not work
Does this mean that these components will no longer work?
for new versions

I also noticed
an empty form is created first,
after a few seconds it appears TMSFNCListBox1

We haven't tested yet with Lazarus 2.1.0, as of now, 2.1.0 is still not officially released. Also, we have been in touch with the Lazarus team and they confirm that there are issues in 2.0.10 and 2.0.12 regarding installing packages. Please use 2.0.8 for now until we have more info. It's unclear exactly what you mean with "after a few seconds it appears TMSFNCListBox1". We haven't experienced issues here.

An empty form without components appears first.
After a few seconds the components also appear.

Your recommendation is to use 2.0.12:
"We are currently only supporting the official Lazarus version available for download at which is version 2.0.12 which comes with the default FPC version of 3.2.0, all other newer versions or other custom FPC versions are not supported."
apply the style, "$type" property not found in Object descriptor - #12 by Pieter_Scheldeman

The recommendation came before the package issues. Unfortunately, there are package issues in 2.0.12. Luckily, a user found a workaround to get them installed. We are currently investigating a long term solution.

  1. LCLTMSFNCCorePkg.lpk >> Install
  2. LCLTMSFNCCorePkgDE.lpk >> Install >> Error
  3. LCLTMSFNCCorePkg.lpk >> Only compile
  4. LCLTMSFNCCorePkgDE.lpk >> Install >> OK
  5. LCLTMSFNCUIPackPkg.lpk >> Install
  6. LCLTMSFNCUIPackPkgDE.lpk >> Install >> Error
  7. LCLTMSFNCUIPackPkg.lpk>> Only compile
  8. LCLTMSFNCUIPackPkgDE.lpk >> Install >> OK

That's my way of compiling

Can you now recommend me which version to use
2.0.8 or 2.0.12

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.