TTMSFMXPlanner invisible items problem on IOS

Good Evening,

I've got a strange problem with the TTMSFMXPlanner which occurs only on IOS:

The planner is run in MultiDay-Mode, is populated in a seperate thread, as my app requires it to be updated at runtime, and the populating itself is done in completely standard fashion:

[Generating the items]

This works perfectly fine on Android, on which the Planner is immediately updated with all the items being visible.
On IOS however, the planner appears empty, yet when I tap the location of an item which I know to be there, it becomes visible.
Similary all items become visible when I go one day forward and back, or alternatively use a rescaling-method which changes the Timeline.DisplayUnit at runtime.

I already tried to circumvent the problem in several ways, like:

- ordering the planner per code to navigate one day forward and back after the update, which interestingly also at first doesn't do anything, yet as soon as I tap the planner, it navigates one day forward

- calling .Repaint manually after update, which doesn't do anything

- calling my method that affects TimeLine.DisplayUnit several times after the Update, which is cumbersome and doesn't work either

I am kind of clueless at this point as it works fine on Android, just not on IOS, which indicates that it could be a problem of the component.
In any way I would be very grateful if you could offer a hint or even better a solution for my problem.


The planner needs to be synchronized with the main thread to avoid painting issues. Are you synchronizing the BeginUpdate/EndUpdate?


indeed, I just looked it up and found that the populating wasn´t synchronized...
What a stupid mistake... corrected it and now it works fine.
Thank you very much!