TTMSFMXGrid - disappearing rows when appending


I have a grid bound to a SQLite3 table through a TLiteQuery component. It is looking good and generally behaving very well. I have one artifact when appending records through a child form. The child form has TEdit fields with LiveBinding and is working well too.

So I call

And some of the rows in the underlying grid go blank while in the child form, but none of the data is affected. It seems to be the selected row and any row beneath it. I have tried calling gridUsers.BeginUpdate and gridUsers.EndUpdate before and after the Append and ShowModal call. It does not help.

Pics attached. How do I get rid of this odd drawing artifact? Thanks!
- Scott

Before Append and ShowModal:

After Append and ShowModal:


Can you try calling DisableControls / EnableControls on dataset level wrapping the dialog?. There is no need to call BeginUpdate/EndUpdate.

Calling DisableControls and EnableControls would be a bit of a problem since the child form is the add/edit form for the same table, and it has livebinding controls on it from the same table.

I did replace my form showmodal with a dialogbox to try it out, and the problem still exists, and disablecontrols and enablecontrols did stop the visual behavior problem, but that isn't a fix in any way.

If there is a way to freeze the grid during the operation, that would do it. Otherwise it is an unfortunate behavior.

- Scott


If you have a small sample that demonstrates this, we can investigate here what exactly is going wrong. Are you manipulating the dataset, using beginupdate/endupdate in any other way? There must be a reason why the data is not shown starting from the selected row.


Still working on a sample. The dataset is a DevArt TLiteQuery connecting to a SQLite3 database. I have a simple SELECT query connected to the TMS grid. It edits and appends great, just like I have done with a dozen other dataset projects, but this is my first using DevArt's component. There are a number of settings in TLiteQuery that might influence it. I am attempting to create a plain test case where I just have the query component connected to a plain FMX grid using the wizard binding and seeing if it has the same behavior, then it is definitely a DevArt issue.

Will post shortly.

So I tried making a clean sample of a TLiteQuery connected to the TMS Grid and it does not have the same behavior when I append, show a dialog and cancel. Even with row select and using Order By in the query.

So I don't know where the blank row behavior is coming from.I will post an answer if I figure it out.

- Scott


Thank you for your feedback. It's unclear though what the difference is between the 2 samples, but if you manage to reproduce this, please let us know so we can investigate this here.